Bug 118965 - redhat-config-cluster failure
redhat-config-cluster failure
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-23 06:06 EST by Gerald Schmid
Modified: 2009-04-16 15:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-24 10:11:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Schmid 2004-03-23 06:06:59 EST
Description of problem:

redhat-config-cluster on rhe 3 AS update1 could not be started.

following errors are shown:

[root@icodatena configure]# /usr/sbin/cluster-config
Traceback (most recent call last):
  File "/usr/sbin/cluster-config", line 35, in ?
    from clusterpkg.cluconfig_module import cluconfig
  File "clusterpkg/cluconfig_module.py", line 11, in ?
    from clusterpkg.services_module   import services
  File
"/usr/share/redhat-config-cluster/configure/clusterpkg/services_module.py",
line 3, in ?
    from clusterpkg.service_module import service
  File
"/usr/share/redhat-config-cluster/configure/clusterpkg/service_module.py",
line 4, in ?
    from clusterpkg.service_device_module import device
  File
"/usr/share/redhat-config-cluster/configure/clusterpkg/service_device_module.py",
line 7, in ?
    from clusterpkg.util_smbconf_module import smbConf
  File
"/usr/share/redhat-config-cluster/configure/clusterpkg/util_smbconf_module.py",
line 55, in ?
    FILE_HEADER = _("""
NameError: name '_' is not defined

starting cluster-config:

Traceback (most recent call last):
  File "/usr/sbin/cluster-config", line 35, in ?
    from clusterpkg.cluconfig_module import cluconfig
  File "clusterpkg/cluconfig_module.py", line 11, in ?
  File
"/usr/share/redhat-config-cluster/configure/clusterpkg/services_module.py",
line 3, in ?
    from clusterpkg.service_module import service
  File
"/usr/share/redhat-config-cluster/configure/clusterpkg/service_module.py",
line 4, in ?
    from clusterpkg.service_device_module import device
  File
"/usr/share/redhat-config-cluster/configure/clusterpkg/service_device_module.py",
line 7, in ?
    from clusterpkg.util_smbconf_module import smbConf
  File
"/usr/share/redhat-config-cluster/configure/clusterpkg/util_smbconf_module.py",
line 55, in ?
    FILE_HEADER = _("""
NameError: name '_' is not defined



Version-Release number of selected component (if applicable):

redhat-config-cluster-1.0.0-5
clumanager-1.2.3-1
python-2.2.3-5
rh-cs-de-3-1.noarch.rpm
rh-cs-en-3-1.noarch.rpm
ipvsadm-1.21-9.ipvs108

How reproducible:

every time it is started

also look at:

https://listman.redhat.com/archives/rhn-users/2004-March/msg00015.html
Comment 1 Gerald Schmid 2004-03-24 06:51:46 EST
We found the solution:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=112933
We isntalled PyXML, so all is o.k.
Comment 2 Jim Parsons 2004-03-24 10:11:49 EST
This PyXML dependency was put in the rpm spec file for bz #112933. The
first build that includes this is 1.0.1-4.1  Closing this as 'not a bug'.

Note You need to log in before you can comment on or make changes to this bug.