Bug 118966 - missing buildrequires for libcroco
missing buildrequires for libcroco
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-03-23 06:35 EST by Huw Lynes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-06-18 11:36:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Huw Lynes 2004-03-23 06:35:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
SRPM for gdm on FC1 has a build dependency on libcroco which isn't
mentioned in the BuildRequires section of gdm.spec

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.rpm -e libcroco-devel
2.rpmbuild -ba gdm.spec
3.build fails during configure

Actual Results:  checking GUING_LIBS... -Wl,--export-dynamic
-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm
-lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0
-ldl -lglib-2.0  
checking for gtk+-2.0 >= 1.3.1 libgnomecanvas-2.0 >= 1.109.0
librsvg-2.0 >= 1.1.1 libxml-2.0 >= 2.4.12 libart-2.0 >= 2.3.11...
Package libcroco was not found in the pkg-config search path.
Perhaps you should add the directory containing `libcroco.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libcroco', required by 'librsvg', not found

configure: error: Library requirements (gtk+-2.0 >= 1.3.1
libgnomecanvas-2.0 >= 1.109.0 librsvg-2.0 >= 1.1.1 libxml-2.0 >=
2.4.12 libart-2.0 >= 2.3.11) not met; consider adjusting the
PKG_CONFIG_PATH environment variable if your libraries are in a
nonstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.43831 (%build)

Expected Results:  after adding BuidRequires: libcroco-devel >= 0.3

rpmbuild -ba gdm.spec

error: Failed build dependencies:
        libcroco-devel >= 0.3 is needed by gdm-

Additional info:
Comment 1 Huw Lynes 2004-06-18 11:36:45 EDT
looks like this has been fixed in gdm- 

Note You need to log in before you can comment on or make changes to this bug.