Bug 119027 - gtk2 needs BuildPrereq: gtk-doc
gtk2 needs BuildPrereq: gtk-doc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-23 18:30 EST by Tom "spot" Callaway
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-20 10:04:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2004-03-23 18:30:18 EST
gtk2 needs BuildPrereq: gtk-doc
Comment 1 Pawel Salek 2004-05-03 18:18:34 EDT
This does not seem to be the only build problem. After gtk-doc
installation, I get:

RPM build errors:
    File not found by glob:
/var/tmp/gtk-2.4.0-root/usr/lib/libgtk-x11-2.0.so.*
    File not found by glob:
/var/tmp/gtk-2.4.0-root/usr/lib/libgdk-x11-2.0.so.*
    File not found by glob:
/var/tmp/gtk-2.4.0-root/usr/lib/libgdk_pixbuf-2.0.so.*
    File not found by glob:
/var/tmp/gtk-2.4.0-root/usr/lib/libgdk_pixbuf_xlib-2.0.so.*
    File not found by glob: /var/tmp/gtk-2.4.0-root/usr/lib/lib*.so

The directory contains:
[pawsa@nora pawsa]$ ll /var/tmp/gtk-2.4.0-root/usr/lib
total 18824
drwxr-xr-x  4 pawsa pawsa     4096 May  3 23:42 gtk-2.0
lrwxrwxrwx  1 pawsa pawsa       25 May  3 23:42 libgdk_pixbuf-2.0 ->
libgdk_pixbuf-2.0.0.400.0
lrwxrwxrwx  1 pawsa pawsa       25 May  3 23:42 libgdk_pixbuf-2.0.0 ->
libgdk_pixbuf-2.0.0.400.0
-rwxr-xr-x  1 pawsa pawsa   392587 May  3 23:42 libgdk_pixbuf-2.0.0.400.0
lrwxrwxrwx  1 pawsa pawsa       30 May  3 23:42 libgdk_pixbuf_xlib-2.0
-> libgdk_pixbuf_xlib-2.0.0.400.0
lrwxrwxrwx  1 pawsa pawsa       30 May  3 23:42
libgdk_pixbuf_xlib-2.0.0 -> libgdk_pixbuf_xlib-2.0.0.400.0
-rwxr-xr-x  1 pawsa pawsa   271742 May  3 23:42
libgdk_pixbuf_xlib-2.0.0.400.0
lrwxrwxrwx  1 pawsa pawsa       22 May  3 23:42 libgdk-x11-2.0 ->
libgdk-x11-2.0.0.400.0
lrwxrwxrwx  1 pawsa pawsa       22 May  3 23:42 libgdk-x11-2.0.0 ->
libgdk-x11-2.0.0.400.0
-rwxr-xr-x  1 pawsa pawsa  3753056 May  3 23:42 libgdk-x11-2.0.0.400.0
lrwxrwxrwx  1 pawsa pawsa       22 May  3 23:42 libgtk-x11-2.0 ->
libgtk-x11-2.0.0.400.0
lrwxrwxrwx  1 pawsa pawsa       22 May  3 23:42 libgtk-x11-2.0.0 ->
libgtk-x11-2.0.0.400.0
-rwxr-xr-x  1 pawsa pawsa 14810163 May  3 23:42 libgtk-x11-2.0.0.400.0
drwxr-xr-x  2 pawsa pawsa     4096 May  3 23:42 pkgconfig

 *.so extension is missing.
Comment 2 Matthias Clasen 2004-05-20 10:04:50 EDT
I've removed the requirement for gtk-doc by not autogen'ing (not
necessary since there are currently no auto-modifying patches). Don't
know about the other problem. If it still happens, please open a
separate bug for that.

Note You need to log in before you can comment on or make changes to this bug.