Bug 119028 - mt fails to set or get density
mt fails to set or get density
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mt-st (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-23 18:31 EST by Ryan Lovett
Modified: 2013-07-02 18:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 08:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Lovett 2004-03-23 18:31:25 EST
Description of problem:
 After initializing the tape device with stinit, 'mt status' correctly
reports the tape density. A second invocation of 'mt status', however,
reports the wrong density. mt will not correctly report the tape
density until stinit is run again.

Version-Release number of selected component (if applicable):
mt-st v. 0.7

How reproducible:
Always

Steps to Reproduce:
1. Run stinit
2. Run mt status
3. Run mt status
  
Actual results:
The second invocation reports a density that is different from the
first invocation.

Expected results:
Querying the tape device should not unset the tape density.

Additional info:
$ cat /etc/stinit.def
# mode1 /dev/st0  "high density"
# mode2 /dev/st0l "low density"
# mode3 /dev/st0m "medium density"
# mode4 /dev/st0a "auto-seeking density"
 
# HP DDS4
manufacturer="HP" model="C5683A"
{
scsi2logical=1
can-bsr can-partitions auto-lock density=0x26
mode1 blocksize=0 compression=1
mode2 blocksize=10240 compression=0
mode3 blocksize=0 compression=1
mode4 blocksize=10240 compression=1
}

root@scf:/etc# stinit
Initialized 1 tape device.
root@scf:/etc# dmesg|tail
st0: Default block size set to 0 bytes.
st0: Density default set to 26
st0: Compression default set to 1
st0: Mode 3 options: buffer writes: 1, async writes: 1, read ahead: 1
st0:    can bsr: 1, two FMs: 0, fast mteom: 0, auto lock: 1,
st0:    defs for wr: 0, no block limits: 0, partitions: 1, s2 log: 1
st0:    sysv: 0 nowait: 0
st0: Default block size set to 10240 bytes.
st0: Density default set to 26
st0: Compression default set to 1
root@scf-pc11:/etc# mt -f /dev/st0 status
SCSI 2 tape drive:
File number=0, block number=0, partition=0.
Tape block size 0 bytes. Density code 0x26 (DDS-4 or QIC-4GB).
Soft error count since last status=0
General status bits on (41010000):
 BOT ONLINE IM_REP_EN
root@scf:/etc# mt -f /dev/st0 status
SCSI 2 tape drive:
File number=0, block number=0, partition=0.
Tape block size 0 bytes. Density code 0x8c (EXB-8505 compressed).
Soft error count since last status=0
General status bits on (41010000):
 BOT ONLINE IM_REP_EN
Comment 1 Jindrich Novy 2004-09-08 04:53:29 EDT
Hello Ryan,

is it still a problem with mt-st-0.8? (available rawhide)

Jindrich

Note You need to log in before you can comment on or make changes to this bug.