Bug 119054 - LTC7037-kickstart not accepting firewall settings
LTC7037-kickstart not accepting firewall settings
Status: CLOSED DUPLICATE of bug 123867
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-24 10:51 EST by Bill Goodrich
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Goodrich 2004-03-24 10:51:52 EST
The following has be reported by IBM LTC:  
kickstart not accepting firewall settings
Hardware Environment:
z990
Software Environment:
rhel3 u2 beta 1

Steps to Reproduce:
1.kickstart install
2.
3.

Actual Results:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1042, in ?
    instClass.setInstallData(id)
  File "/usr/lib/anaconda/kickstart.py", line 1218, in setInstallData
    self.readKickstart(id, self.file)
  File "/usr/lib/anaconda/kickstart.py", line 677, in readKickstart
    handlers[args[0]](id, args[1:])
  File "/usr/lib/anaconda/kickstart.py", line 100, in doFirewall
    [ 'dhcp', 'ssh', 'telnet', 'smtp', 'http', 'ftp', 'enabled',
  File "/usr/lib/anaconda/isys.py", line 443, in getopt
    return apply(_isys.getopt, args)
TypeError: bad argument --port=smtp:tcp: unknown option

Expected Results:

These settings were created by a successful install. 
It was expected that we would not need to modify the statements in
anyway. 

Additional Information:
this is from the kickstart file: 

firewall --enabled --port=smtp:tcp --port=http:tcp --port=ftp:tcp
--port=ssh:tcp
--port=telnet:tcp
Comment 1 Bill Goodrich 2004-03-24 14:01:18 EST
It looks like the format changed. 

Correct format:
firewall --high --smtp --http --ftp --ssh --telnet

I tried this and it worked. 

/root/anaconda-ks.cfg is still being created with the 
old format. 
Comment 2 Bob Johnson 2004-04-15 09:26:16 EDT
Bill, Still broken ?
Comment 3 Bill Goodrich 2004-04-22 10:47:44 EDT
It's still broken as of U2 Beta 2. 
Comment 4 Jeremy Katz 2004-05-21 17:56:29 EDT

*** This bug has been marked as a duplicate of 123867 ***
Comment 5 Bill Goodrich 2004-08-11 09:50:09 EDT
Still broken in U3 public beta
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.