Bug 119054 - LTC7037-kickstart not accepting firewall settings
Summary: LTC7037-kickstart not accepting firewall settings
Status: CLOSED DUPLICATE of bug 123867
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2004-03-24 15:51 UTC by Bill Goodrich
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 19:02:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Bill Goodrich 2004-03-24 15:51:52 UTC
The following has be reported by IBM LTC:  
kickstart not accepting firewall settings
Hardware Environment:
Software Environment:
rhel3 u2 beta 1

Steps to Reproduce:
1.kickstart install

Actual Results:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1042, in ?
  File "/usr/lib/anaconda/kickstart.py", line 1218, in setInstallData
    self.readKickstart(id, self.file)
  File "/usr/lib/anaconda/kickstart.py", line 677, in readKickstart
    handlers[args[0]](id, args[1:])
  File "/usr/lib/anaconda/kickstart.py", line 100, in doFirewall
    [ 'dhcp', 'ssh', 'telnet', 'smtp', 'http', 'ftp', 'enabled',
  File "/usr/lib/anaconda/isys.py", line 443, in getopt
    return apply(_isys.getopt, args)
TypeError: bad argument --port=smtp:tcp: unknown option

Expected Results:

These settings were created by a successful install. 
It was expected that we would not need to modify the statements in

Additional Information:
this is from the kickstart file: 

firewall --enabled --port=smtp:tcp --port=http:tcp --port=ftp:tcp

Comment 1 Bill Goodrich 2004-03-24 19:01:18 UTC
It looks like the format changed. 

Correct format:
firewall --high --smtp --http --ftp --ssh --telnet

I tried this and it worked. 

/root/anaconda-ks.cfg is still being created with the 
old format. 

Comment 2 Bob Johnson 2004-04-15 13:26:16 UTC
Bill, Still broken ?

Comment 3 Bill Goodrich 2004-04-22 14:47:44 UTC
It's still broken as of U2 Beta 2. 

Comment 4 Jeremy Katz 2004-05-21 21:56:29 UTC

*** This bug has been marked as a duplicate of 123867 ***

Comment 5 Bill Goodrich 2004-08-11 13:50:09 UTC
Still broken in U3 public beta

Comment 6 Red Hat Bugzilla 2006-02-21 19:02:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.