Bug 119123 - APM subsystem crash with SMP (HYPERTHREADED) system
APM subsystem crash with SMP (HYPERTHREADED) system
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-25 04:38 EST by Michele Codutti
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:28:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michele Codutti 2004-03-25 04:38:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.4) Gecko/20030922

Description of problem:
On a system with P4 (NorthWood-C) with hyperthreading activated and
Intel 865GV chipset I have passed apm=power-off to the kernel to
enable the shutdown of the machine. This causes a kernel panic on boot
with this error message:
Kernel bug at apm.c:1743


Version-Release number of selected component (if applicable):
kernel-2.4.21-9.0.1.EL

How reproducible:
Always

Steps to Reproduce:
1.Add "apm=power-off" to the grub image that loads a SMP kernel.
2.Reboot the machine.
3.Select the kernel with "apm=power-off" option.

Actual Results:  Kernel Panic

Expected Results:  Normal startup and clean shutdown

Additional info:

The PC is an MSI HETIS
URL:
http://www.msi.com.tw/program/products/slim_pc/slm/pro_slm_detail.php?kind=4&CHIP=54&NAME=Hetis%20Series
Comment 4 Steve Cleveland 2004-08-25 13:08:18 EDT
I am having the same problem with kernel 2.4.21-15.0.4.  Has there
been any progress made?

The machine is a Dell Optiplex GX270 w/ Hyperthreading enabled.
Comment 5 Ernie Petrides 2004-11-15 16:17:42 EST
Ingo, could you please pick this up?  DaveJ is really swamped with U4.
Comment 6 Ingo Molnar 2005-09-15 12:57:54 EDT
Does this problem still occur with more recent kernels?
Comment 7 Michele Codutti 2005-09-16 09:42:34 EDT
I don't know I sell the machine six month ago because of this bug.
Comment 8 Michele Codutti 2005-09-16 09:44:05 EDT
(In reply to comment #7)
> I don't know I sell the machine six month ago because of this bug.

Sorry for my syntax error:
I SOLD the machine six month ago because of this bug.
Comment 10 RHEL Product and Program Management 2007-10-19 15:28:29 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.