Bug 119124 - mdadm, sync failed when creating raid level 1 disks
mdadm, sync failed when creating raid level 1 disks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mdadm (Show other bugs)
3.0
s390x Linux
high Severity high
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-25 05:49 EST by Arnold Fox
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-16 11:55:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error messages & log file (6.57 KB, text/plain)
2004-03-25 05:59 EST, Arnold Fox
no flags Details

  None (edit)
Description Arnold Fox 2004-03-25 05:49:32 EST
Description of problem:

mdadm failed to build raid level 1 disks



Version-Release number of selected component (if applicable):
mdadm-1.4.0-1
kernel-2.4.21-9.EL


How reproducible:
every time


Steps to Reproduce:
Create or assemble a raid1 disk
   mdadm --create /dev/md0 --level=1 --raid-devices=2 /dev/dasd[vj]1
or
   mdadm --assemble /dev/md0 /dev/dasd[vj]1

  
Actual results:
raid level 1 disk starts with just 1 volume

md0 : active raid1 dasdv1[1] dasdj1[0](F)
      2403904 blocks [2/1] [_U]

Expected results:


Additional info:

system config:
   RHEL AS 3 Update 1 runing in LPAR mode
   3390 type 3 volumes on ESS800 (ficon direct attached)

linear and raid level 0 disks are working fine
Comment 1 Arnold Fox 2004-03-25 05:59:46 EST
Created attachment 98845 [details]
error messages & log file
Comment 2 Georg Markgraf 2004-03-25 08:38:54 EST
Looking into the log, the problem is:
 'md'  generates requests with a size of 2048 bytes, the dasd is 
formattet with a block size of 4096 bytes.!
=> correct the md 
(from the Syslog:)
Mar 24 17:17:11 boelinlp10 kernel: dasd(eckd): ignoring bogus sized 
request: 2048<4096
Mar 24 17:17:11 boelinlp10 kernel: dasd: (b006) CCW creation failed 
on request 00000000fa32e900
Comment 8 Mike Gahagan 2005-02-16 11:55:38 EST
This should be fixed since U2, please re-open the bug if you still see this
problem with the lastest update (U4).

Note You need to log in before you can comment on or make changes to this bug.