This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11913 - no shell for the listar account & wrong home dir bits
no shell for the listar account & wrong home dir bits
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: listar (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
http://www.listar.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-05 11:14 EDT by Sergio A. Kessler
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-06 15:17:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergio A. Kessler 2000-06-05 11:14:17 EDT
when the listar.listar user.group is created, the shell is assigned 
to /bin/false, impeding doing su - listar to create lists with the propers
permiss.

Also the directory /home/listar is created as 700, impeding sendmail
to search in that directory to execute the listar executable.
Comment 1 Tim Powers 2000-06-05 11:56:30 EDT
You should try out the version in rawhide. It has been reworked quite a bit in
the spec file, the home dir is /var/listar as well (FHS compliance). Here is a
file listing from the newer package in rawhide:

drwxr-xr-x 1 listar listar 4096 Jun  1 19:29 /usr/share/doc/listar-0.129a
-rw-r--r-- 1 listar listar 138556 Apr 17 19:09
/usr/share/doc/listar-0.129a/CHANGELOG
-rw-r--r-- 1 listar listar 18011 Apr 17 19:09
/usr/share/doc/listar-0.129a/LICENSE
-rw-r--r-- 1 listar listar 501 Apr 17 19:09 /usr/share/doc/listar-0.129a/NOTE
-rw-r--r-- 1 listar listar 947 Apr 17 19:09
/usr/share/doc/listar-0.129a/PLATFORMS
-rw-r--r-- 1 listar listar 5483 Apr 17 19:09 /usr/share/doc/listar-0.129a/README
-rw-r--r-- 1 listar listar 1218 Apr 17 19:09
/usr/share/doc/listar-0.129a/README.126
-rw-r--r-- 1 listar listar 531 Apr 17 19:09
/usr/share/doc/listar-0.129a/README.ANTISPAM
-rw-r--r-- 1 listar listar 1977 Apr 17 19:09
/usr/share/doc/listar-0.129a/README.CVS
-rw-r--r-- 1 listar listar 3310 Apr 17 19:09
/usr/share/doc/listar-0.129a/README.DIGEST
-rw-r--r-- 1 listar listar 488 Apr 17 19:09
/usr/share/doc/listar-0.129a/README.LISTS
-rwxr-xr-x 1 listar listar 19 Jun  1 19:29 /var/listar/banned
-rwsr-xr-x 1 listar listar 188924 Jun  1 19:29 /var/listar/listar
-rwxr-xr-x 1 listar listar 100 Jun  1 19:29 /var/listar/listar.aliases
-rwxr-xr-x 1 listar listar 9052 Jun  1 19:29 /var/listar/listar.cfg
-rwxr-xr-x 1 listar listar 3734 Jun  1 19:29 /var/listar/listar.hlp
drwxr-x--x 1 listar listar 4096 Jun  1 19:29 /var/listar/lists
-rwxr-x--- 1 listar listar 62168 Jun  1 19:29 /var/listar/modules/acctmgr.lpm
-rwxr-x--- 1 listar listar 24328 Jun  1 19:29 /var/listar/modules/admin.lpm
-rwxr-x--- 1 listar listar 11008 Jun  1 19:29
/var/listar/modules/administrivia.lpm
-rwxr-x--- 1 listar listar 8484 Jun  1 19:29 /var/listar/modules/antispam.lpm
-rwxr-x--- 1 listar listar 11220 Jun  1 19:29 /var/listar/modules/base.lpm
-rwxr-x--- 1 listar listar 29064 Jun  1 19:29 /var/listar/modules/bouncer.lpm
-rwxr-x--- 1 listar listar 34164 Jun  1 19:29 /var/listar/modules/digest.lpm
-rwxr-x--- 1 listar listar 10416 Jun  1 19:29
/var/listar/modules/filearchive.lpm
-rwxr-x--- 1 listar listar 10832 Jun  1 19:29
/var/listar/modules/listarchive.lpm
-rwxr-x--- 1 listar listar 66988 Jun  1 19:29 /var/listar/modules/lsg2.lpm
-rwxr-x--- 1 listar listar 11448 Jun  1 19:29 /var/listar/modules/pantomime.lpm
-rwxr-x--- 1 listar listar 8768 Jun  1 19:29 /var/listar/modules/password.lpm
-rwxr-x--- 1 listar listar 58948 Jun  1 19:29 /var/listar/modules/send.lpm
-rwxr-x--- 1 listar listar 27860 Jun  1 19:29 /var/listar/modules/stat.lpm
-rwxr-x--- 1 listar listar 13920 Jun  1 19:29 /var/listar/modules/toolbox.lpm
drwxr-x--- 1 listar listar 4096 Jun  1 19:29 /var/listar/queue
-rwxr-xr-x 1 listar listar 1546 Jun  1 19:29 /var/listar/scripts/fixlist.pl.dist
-rwxr-xr-x 1 listar listar 36 Jun  1 19:29 /var/listar/scripts/lsg2.cgi.dist
-rwxr-xr-x 1 listar listar 2453 Jun  1 19:29 /var/listar/spam-regexp.sample

If you can try this one out it should work for you. Also, if you change
/etc/passwd to read /bin/bash for the shell does it work for you?

Tim
Comment 2 Tim Powers 2000-07-06 15:17:31 EDT
I am closing this bug since there hasn't been a response since the bug was
reported. Please reopenit if there are still issues.

Tim

Note You need to log in before you can comment on or make changes to this bug.