This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 119148 - Xserver tries to start on new display after Gnome logout
Xserver tries to start on new display after Gnome logout
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gdm (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-25 11:16 EST by Christopher Martinsen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 13:57:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Martinsen 2004-03-25 11:16:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20040107 Galeon/1.3.7

Description of problem:
This is a new deployment of RH WS 3.0 for my organization. We are
replacing our existing RH 7.3 installations. 

When a user logs out of Gnome Desktop or a machine is rebooted after
the person has been logged in, we get the error popping up that says:

There already appears to be an X server running on display :0
Should I try another display number? If you select <No> X tries to
restart itself and fails.

I have been unable after this to get X running again on the system. I
have had to reinstall from my master image to get the workstation
usable again.

I have this happening on two systems. One is a Dell Dimension 4400 and
one is an Optiplex GX240. 

Version-Release number of selected component (if applicable):
XFree86-4.3.0-55.EL, gdm-2.4.1.6-2.i386.rpm

How reproducible:
Sometimes

Steps to Reproduce:
1. Have the user log out of Gnome
2. Restart the system, or sometimes the logout will fail.
3. The X server startup will fail.
    

Expected Results:  The X display manager should come up and allow the
user to login to the system under runlevel 5.

Additional info:
Comment 1 Mike A. Harris 2004-03-26 02:29:49 EST
I believe this is a gdm bug rather than an XFree86 bug.  If there
is an X server already running, it stands to reason that it's only
because gdm hasn't removed the previous X server invocation.

In other words, the X server just runs until it is killed by something
else.  If it is running and gdm tries to start another one on the
same display, then I would consider that to be a gdm bug, as it
should either:

1) Kill the previous X server first.

or

2) Start the X server on a new display.

Reassigning to gdm component for further investigation/comment.
Comment 2 Mike A. Harris 2004-03-26 04:36:20 EST
Hi Christopher,

I just tried to reproduce this with gdm on RHEL 3, and wasn't able
to reproduce.  Is there something specific about your configuration
perhaps that might be causing this?

What video hardware are you using, and what video driver?

That might help provide additional clues as to what may be happening.

Thanks in advance!
Comment 3 Ray Strode [halfline] 2005-09-09 13:57:11 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is still reproduceable, please contact the Red
Hat Global Support Services page on our website for technical support options:
https://www.redhat.com/support

If you have a telephone based support contract, you may contact Red Hat at
1-888-GO-REDHAT for technical support for the problem you are experiencing. 

Note You need to log in before you can comment on or make changes to this bug.