Bug 119172 - g77 compiler crash
Summary: g77 compiler crash
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc3   
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: ftp://ftp.comco.com/outgoing/test.F
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-25 21:54 UTC by Tadeusz Liszka
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 09:45:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
g77 source code (10.86 KB, text/plain)
2004-03-25 21:57 UTC, Tadeusz Liszka
no flags Details

Description Tadeusz Liszka 2004-03-25 21:54:49 UTC
Description of problem:
g77 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE  -ffast-math
-march=pentiumpro -malign-double -Wno-globals -fno-globals -c
reader/util_2.F -g  -Iheader -Ibcs  -DC_Linux=1 -DLinux_0=1
-DBUILDID=\"0210662_0101000_L0_d\" -DH3D -o _obj_Linux_d/util_2.o
reader/util_2.F: In subroutine `squeez':
reader/util_2.F:362: Internal compiler error in gen_subprogram_die, at
dwarf2out.c:10352
Please submit a full bug report,


Version-Release number of selected component (if applicable):
gcc-g77-3.2.3-24

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
compiler crash

Expected results:
error message

Additional info:
It is combination of duplicate procedure name with this particular set
of compiler options. simple g77 -g does not crash.

Comment 1 Tadeusz Liszka 2004-03-25 21:57:25 UTC
Created attachment 98862 [details]
g77 source code

Comment 2 Jakub Jelinek 2004-05-27 12:07:28 UTC
Reproduced also with gcc-g77-3.3.3-6.

Comment 3 Jakub Jelinek 2004-05-27 12:37:30 UTC
-fno-globals seems to be really broken by design option.
It allows creating assembly output which will not assemble (duplicate
squeez_ routine).

Comment 4 Jakub Jelinek 2004-05-27 15:20:36 UTC
http://gcc.gnu.org/PR15683


Note You need to log in before you can comment on or make changes to this bug.