Bug 119195 - The X server warning message when /dev/apm_bios can't be opened is misleading
The X server warning message when /dev/apm_bios can't be opened is misleading
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 119196 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-26 03:16 EST by Mike A. Harris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-23 14:51:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2004-03-26 03:16:20 EST
When the X server starts, it attempts to open /dev/apm_bios normally,
in order to try to access APM services in the kernel.  If the kernel
has APM support built in or loaded, and configured, etc. then APM
support in the X server will generally work.

However, if the user does not have any need for APM support on their
machine and does not have it configured, or does not have a kernel
with APM support loaded, then the X server will not be able to
open /dev/apm_bios.  That is normal behaviour, and not a bug or
a problem of any kind.  In this case, the X server realizes that
it is unable to access the kernel's APM functions, and it just
disables APM support.

Users who do not want/need APM support don't need to know or care
about this.  However, the X server logs a line to the X server
log file when it is unable to open the APM device, which scares
a lot of users, who often think this is some kind of error, and
may be responsible for some random problem they are having with
the X server.

(WW) Open APM failed (/dev/apm_bios) (No such device)

Since the error message given above by the X server is not very
detailed or informative to the average user, it is not surprising
that many users consider this to be the cause of random problems,
when it is just a harmless message.  Most users probably don't even
know what APM is, and are thus even more likely to think this (WW)
warning is the cause of their problems.


Solution:

The above error message should be modified to be more informative
to users in the log file, and be downgraded from (WW) warning to
(II) info level.  Something like:

(II) Operating system APM services via /dev/apm_bios are unavailable,
     so APM power management features in the X server will not be
     used.  If you require APM power management features, please
     ensure your BIOS and operating system kernel are configured to
     provide APM services.  This message is just an informative
     message which can be safely ignored, and is not an error.
Comment 1 Alan Cox 2004-05-03 11:50:14 EDT
*** Bug 119196 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2004-12-23 14:51:32 EST
Filed upstream as: https://bugs.freedesktop.org/show_bug.cgi?id=2141

Setting status to "UPSTREAM"

Note You need to log in before you can comment on or make changes to this bug.