Bug 119218 - Gconf crashes for frequent login/logout users
Gconf crashes for frequent login/logout users
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-26 10:33 EST by Tom Cross
Modified: 2013-04-02 00:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 08:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Cross 2004-03-26 10:33:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-10 i686)

Description of problem:
We have Fedora Core 1 loaded on most/all of our desktops here.  A few
desktops are giving me lots of trouble with Gconfd.  People log into
the receptionist desk, logout of receptionist desk, log into their own
desktop and gconf busts big time:

There was an error starting GNOME Settings Daemon....

The last error message was: Child PRocess did not give an error
message, unkown failure occurred.GNOME will still try to restart the
Settings Daemon next time you login.


Then the panel apps start complaining (desktop switcher and tasklist).

This is what ~/.xsession-errors looks like:
SESSION_MANAGER=local/receptionist.kendeco.com:/tmp/.ICE-unix/2683
Gnome-Message: gnome_execute_async_with_env_fds: returning -1
Gnome-Message: gnome_execute_async_with_env_fds: returning -1


I usually "fix" it by hitting control-Alt-BackSpace, login as
root,clean out /tmp, reboot, and then they can log in again.  But it
is a royal PAIN.

Some Details:

We use GDM (DisallowTCP=false, NeverPlaceCookiesOnNFS=false)
Home directories are NFS mounted.
DISPLAY is set to hostname:0 (as in receptionist.kendeco.com:0)
(this is so they can run apps remotely on our servers)
Authentication is using NIS

Version-Release number of selected component (if applicable):
GConf2-2.4.0-1

How reproducible:
Sometimes

Steps to Reproduce:
1.user login
2.user logout
3.user login (maybe on a different desk)
    

Actual Results:  GConfd crashes, or cannot start

Expected Results:  GConfd should at least complain what the actual
problem is instead of just crashing.

Additional info:

We use GDM (DisallowTCP=false, NeverPlaceCookiesOnNFS=false)
Home directories are NFS mounted.
DISPLAY is set to hostname:0 (as in receptionist.kendeco.com:0)
  (this is so they can run apps remotely on our servers)
Authentication is using NIS
Comment 1 Tom Cross 2004-03-26 11:02:24 EST
Added a bugzilla upstream on GNOME:

http://bugzilla.gnome.org/show_bug.cgi?id=138226
Comment 2 Mark McLoughlin 2004-04-19 03:48:16 EDT
The error you are seeing is because gnome-session is failing to start
gnome-settings-daemon.

Moving to control-center

Note You need to log in before you can comment on or make changes to this bug.