This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 119227 - UPGRADE: Persistence error on Oracle creating content item
UPGRADE: Persistence error on Oracle creating content item
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vadim Nasardinov
Jon Orris
:
Depends On:
Blocks: 113496
  Show dependency treegraph
 
Reported: 2004-03-26 14:50 EST by Jon Orris
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 10:32:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
System log with persistence logging turned up (141.92 KB, text/plain)
2004-03-26 15:19 EST, Jon Orris
no flags Details
see http://post-office.corp.redhat.com/archives/ccm-engineering-list/2004-March/msg00040.html (505 bytes, patch)
2004-03-26 16:06 EST, Vadim Nasardinov
no flags Details | Diff

  None (edit)
Description Jon Orris 2004-03-26 14:50:09 EST
Description of problem:
@41806/Oracle

Upgrade from 6.0.1
Log in
Create an agenda
Get error:

CCM issue report code: 172.16.64.111:189a628:fb88b348b0

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code: 172.16.64.111:189a628:fb88b348b0 -*-*-*-
-*-*-*- Message 1: com.caucho.jsp.JspLineException: null (root cause:
Unable to send all events to database for object
[com.arsdigita.cms.ContentBundle:{id=321}] because these required
properties are null:) -*-*-*-
-*-*-*- Message 2: com.arsdigita.persistence.FlushException: null
(root cause: Unable to send all events to database for object
[com.arsdigita.cms.ContentBundle:{id=321}] because these required
properties are null:) -*-*-*-
-*-*-*- Message 3: com.redhat.persistence.FlushException: Unable to
send all events to database for object
[com.arsdigita.cms.ContentBundle:{id=321}] because these required
properties are null: -*-*-*-

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: System properties -*-*-*-
ccm.conf: /var/ccm-devel/web/jorris/rickshaw/conf/registry
ccm.home: /var/ccm-devel/web/jorris/rickshaw
com.arsdigita.util.Assert.enabled: true
file.encoding: UTF-8
file.encoding.pkg: sun.io
file.separator: /
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.print.PSPrinterJob
java.class.path:
/home/boston/jorris/dev/lib/classes12.zip:/usr/share/java/junit.jar:/opt/oracle/product/9.2.0.1/jdbc/lib/classes12.jar:/usr/share/java/servletapi4.jar:/opt/resin/2.1.4/lib/jaxp.jar:/opt/resin/2.1.4/lib/dom.jar:/opt/resin/2.1.4/lib/jdbc2_0-stdext.jar:/opt/resin/2.1.4/lib/jdbc-mysql.jar:/opt/resin/2.1.4/lib/jndi.jar:/opt/resin/2.1.4/lib/jmx.jar:/opt/resin/2.1.4/lib/jta-spec1_0_1.jar:/opt/resin/2.1.4/lib/resin.jar:/opt/resin/2.1.4/lib/sax.jar:/opt/resin/2.1.4/lib/webutil.jar:/usr/java/j2sdk1.4.2_03/lib/tools.jar:/usr/java/j2sdk1.4.2_03/jre/lib/rt.jar:/opt/resin/2.1.4/lib/jsdk23.jar
java.class.version: 48.0
java.endorsed.dirs: /usr/java/j2sdk1.4.2_03/jre/lib/endorsed
java.ext.dirs:
/usr/java/j2sdk1.4.2_03/jre/lib/ext:/usr/java/j2sdk1.4.2_03/lib/ext:/var/ccm-devel/web/jorris/rickshaw/webapps/WEB-INF/system:/usr/share/ccm-tools/lib/security
java.home: /usr/java/j2sdk1.4.2_03/jre
java.io.tmpdir: /tmp
java.library.path:
/usr/java/j2sdk1.4.2_03/jre/lib/i386/client:/usr/java/j2sdk1.4.2_03/jre/lib/i386:/usr/java/j2sdk1.4.2_03/jre/../lib/i386:/opt/oracle/product/9.2.0.1/lib:/lib:/usr/lib:/usr/local/lib:libexec
java.naming.factory.initial: com.caucho.naming.InitialContextFactoryImpl
java.naming.factory.url.pkgs: com.caucho.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.4.2_03-b02
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.4
java.util.prefs.PreferencesFactory:
java.util.prefs.FileSystemPreferencesFactory
java.vendor: Sun Microsystems Inc.
java.vendor.url: http://java.sun.com/
java.vendor.url.bug: http://java.sun.com/cgi-bin/bugreport.cgi
java.version: 1.4.2_03
java.vm.info: mixed mode
java.vm.name: Java HotSpot(TM) Client VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: Sun Microsystems Inc.
java.vm.version: 1.4.2_03-b02
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory:
org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory:
com.icl.saxon.TransformerFactoryImpl
line.separator: 

log4j.configuration:
file:///var/ccm-devel/web/jorris/rickshaw/conf/log4j.properties
os.arch: i386
os.name: Linux
os.version: 2.4.21-9.0.1.EL
path.separator: :
resin.home: /var/ccm-devel/web/jorris/rickshaw
sun.arch.data.model: 32
sun.boot.class.path:
/usr/java/j2sdk1.4.2_03/jre/lib/rt.jar:/usr/java/j2sdk1.4.2_03/jre/lib/i18n.jar:/usr/java/j2sdk1.4.2_03/jre/lib/sunrsasign.jar:/usr/java/j2sdk1.4.2_03/jre/lib/jsse.jar:/usr/java/j2sdk1.4.2_03/jre/lib/jce.jar:/usr/java/j2sdk1.4.2_03/jre/lib/charsets.jar:/usr/java/j2sdk1.4.2_03/jre/classes
sun.boot.library.path: /usr/java/j2sdk1.4.2_03/jre/lib/i386
sun.cpu.endian: little
sun.cpu.isalist: 
sun.io.unicode.encoding: UnicodeLittle
sun.java2d.fontpath: 
sun.os.patch.level: unknown
user.country: US
user.dir: /var/ccm-devel/web/jorris/rickshaw
user.home: /home/boston/jorris
user.language: en
user.name: jorris
user.timezone: America/New_York

-*-*-*- Section: Stack trace -*-*-*-
com.redhat.persistence.FlushException: Unable to send all events to
database for object [com.arsdigita.cms.ContentBundle:{id=321}] because
these required properties are null:
	at com.redhat.persistence.Session.assertFlushed(Session.java:557)
	at
com.arsdigita.persistence.DataObjectImpl.assertFlushed(DataObjectImpl.java:446)
	at com.arsdigita.persistence.DataObjectImpl.save(DataObjectImpl.java:429)
	at com.arsdigita.domain.DomainObject.save(DomainObject.java:315)
	at com.arsdigita.cms.ui.authoring.PageCreate.process(PageCreate.java:154)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:490)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:464)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:494)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:356)
	at com.arsdigita.bebop.Form.process(Form.java:440)
	at com.arsdigita.bebop.MetaForm.process(MetaForm.java:160)
	at com.arsdigita.bebop.Form.respond(Form.java:281)
	at com.arsdigita.bebop.PageState.respond(PageState.java:370)
	at com.arsdigita.bebop.Page.process(Page.java:714)
	at com.arsdigita.bebop.Page.process(Page.java:686)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:758)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:281)
	at com.arsdigita.cms.CMSExcursion$1.excurse(CMSExcursion.java:80)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:75)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:296)
	at
_packages._content_22dsection._www._admin._index__jsp._jspService(_index__jsp.java:54)
	at com.caucho.jsp.JavaPage.service(JavaPage.java:75)
	at com.caucho.jsp.Page.subservice(Page.java:485)
	at
com.caucho.server.http.FilterChainPage.doFilter(FilterChainPage.java:182)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:171)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:111)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:105)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:176)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:147)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:291)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:206)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:190)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at
com.arsdigita.web.DispatcherServlet.doService(DispatcherServlet.java:123)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:176)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:147)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:291)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at
com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:534)


-*-*-*- Section: HTTP headers -*-*-*-
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Accept-Encoding: gzip,deflate
Accept-Language: en-us,en;q=0.5
Connection: keep-alive
Content-Length: 2779
Content-Type: multipart/form-data;
boundary=---------------------------6341038438201109881819160234
Cookie: ad_user_login=23!1174938200872!+KjtJxDPiJSg5uXtnsm6Jw==;
JSESSIONID=a_XDbvN-69K5
Host: goodeats.boston.redhat.com:9004
Keep-Alive: 300
Referer:
http://goodeats.boston.redhat.com:9004/ccm/content/admin/index.jsp
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

-*-*-*- Section: Servlet attributes -*-*-*-
com.arsdigita.bebop.PageState: com.arsdigita.bebop.PageState@151a5f9 = {
m_page = com.arsdigita.cms.ui.ContentSectionPage@aa71b,
m_request = com.arsdigita.dispatcher.MultipartHttpServletRequest@18d702e,
m_response = com.caucho.server.http.HttpResponse@167864a,
m_pageState = com.arsdigita.bebop.FormData@1a181b7 = {
m_parameterDataValues = {bbp.820.col={null, []}, bbp.1126.sel={null,
[]}, bbp.387.sel={null, []}, bbp.399.sel={null, []}, bbp.1049.o={null,
[]}, bbp.920.sel={null, []}, bbp.684.sel={null, []},
bbp.886.row={null, []}, bbp.433.col={null, []}, bbp.820.mid={null,
[]}, bbp.626.sel={null, []}, bbp.75.col={null, []}, bbp.793.t={null,
[]}, bbp.1137.sel={null, []}, bbp.125.col={null, []},
bbp.28.bid={null, []}, bbp.94.sel={null, []}, bbp.248.sel={null, []},
bbp.1075.sel={null, []}, bbp.75.row={null, []}, bbp.464.col={null,
[]}, bbp.411.sel={null, []}, bbp.945.sel={193, []}, bbp.807.col={null,
[]}, bbp.1049.mid={null, []}, bbp.35.fldr={null, []},
bbp.276.sel={null, []}, bbp.1148.sel={null, []}, bbp.842.col={null,
[]}, bbp.28.iid={320, []}, bbp.948.stack={[Ljava.lang.Integer;@4b33f6,
[]}, bbp.93.state={null, []}, bbp.807.m={null, []}, page={null, []},
bbp.856.col={null, []}, bbp.177.row={null, []}, bbp.63.srcs={null,
[]}, bbp.807.d={asc, []}, bbp.820.d={asc, []}, bbp.820.o={null, []},
bbp.s={28, []}, bbp.229.stack={null, []}, bbp.308.row={null, []},
bbp.234.sel={null, []}, query={null, []}, bbp.73.sel={1, []},
bbp.698.stack={null, []}, bbp.703.sel={null, []}, bbp.1049.col={null,
[]}, bbp.956.stack={null, []}, g11n.enc={UTF-8, []},
bbp.474.row={null, []}, bbp.418.stack={null, []}, bbp.374.stack={null,
[]}, bbp.1007.sel={null, []},
bbp.689.stack={[Ljava.lang.Integer;@14090f8, []}, bbp.177.col={null,
[]}, bbp.510.sel={null, []}, bbp.916.ch={null, []},
bbp.939.sel_context={, []}, bbp.19.state={ 183 , []}, bbp.807.o={null,
[]}, single_type={null, []}, bbp.856.row={null, []},
bbp.1159.sel={null, []}, bbp.298.row={null, []}, bbp.363.sel={null,
[]}, bbp.652.sel={null, []}, bbp.220.stack={null, []}, bbp.3.pane={0,
[]}, bbp.780.ch={null, []}, bbp.568.sel={null, []}, bbp.1049.d={asc,
[]}, bbp.550.sel={null, []}, bbp.735.sel={null, []},
bbp.753.sel={null, []}, bbp.341.sel={null, []}, bbp.717.sel={null,
[]}, bbp.1035.row={null, []}, bbp.945.state={ 193 , []},
bbp.886.col={null, []}, bbp.433.row={null, []}, bbp.64.target={null,
[]}, bbp.143.row={null, []}, bbp.580.sel={null, []},
bbp.1200.sel={null, []}, bbp.262.sel={null, []}, bbp.563.stack={null,
[]}, bbp.555.stack={null, []}, bbp.143.col={null, []},
bbp.63.act={null, []}, bbp.464.row={null, []}, bbp.786.sc={null, []},
privs_set={null, []}, bbp.1035.col={null, []}, bbp.542.sel={null, []},
bbp.20.ct={55, []}, bbp.v={null, []}, bbp.e={null, []},
bbp.19.sel={183, []}, bbp.1105.sel={null, []}, bbp.298.col={null, []},
bbp.125.row={null, []}, bbp.86.sel={null, []}, bbp.592.sel={null, []},
bbp.842.row={null, []}, bbp.978.sel={null, []}, bbp.i={{22, 104}, []},
bbp.613.row={null, []}, bbp.474.col={null, []}, bbp.1092.sel={null,
[]}, bbp.308.col={null, []}, bbp.50.fldr={null, []}, bbp.1172.sel={55,
[]}, bbp.526.sel={null, []}, bbp.382.stack={null, []},
bbp.793.c={null, []}, bbp.319.sel={null, []}, bbp.69.ps={20, []},
bbp.613.col={null, []}},
m_formErrors = null,
m_model = com.arsdigita.bebop.FormModel@1ed9ad6,
m_locale = en_US,
m_isTransformed = true,
m_isValid = false,
m_isSubmission = true
},
m_attributes = null,
,
m_grabbingComponent = null,
m_invisible = {5, 6, 7, 8, 9, 10, 11, 21, 23, 24, 64, 70, 104, 119,
120, 121, 176, 209, 221, 222, 223, 224, 225, 226, 227, 228, 229, 281,
282, 283, 284, 285, 286, 375, 376, 377, 378, 379, 380, 381, 382, 416,
417, 418, 419, 420, 421, 441, 442, 443, 444, 556, 557, 558, 559, 560,
561, 562, 563, 597, 598, 599, 600, 601, 690, 691, 692, 693, 694, 695,
696, 697, 698, 760, 761, 762, 763, 764, 794, 836, 837, 838, 885, 949,
950, 951, 952, 953, 954, 955, 956, 1012, 1013, 1014, 1015, 1016, 1017,
1018, 1019, 1020, 1021}
}
com.arsdigita.bebop.RequestLocal:
{com.arsdigita.bebop.MetaForm$1@1204291=com.arsdigita.bebop.Form@5062d9
[pageCreate,null,post,false], com.arsdigita.bebop.Form$2@1573f78=,
com.arsdigita.kernel.ui.ACSObjectSelectionModel$1@5bafc=true,
com.arsdigita.kernel.ui.ACSObjectSelectionModel$1@1c404b2=true}
com.arsdigita.cms.dispatcher.section:
[com.arsdigita.cms.ContentSection:{id=187}]
com.arsdigita.dispatcher.OriginalRequest:
com.caucho.server.http.DispatchRequest@2d387
com.arsdigita.dispatcher.RequestContext:
com.arsdigita.sitenode.SiteNodeRequestContext@160f1a7
com.arsdigita.dispatcher.RequestValue:
{com.arsdigita.dispatcher.RequestValue@1c7f72d=null}
com.arsdigita.dispatcher.WrappedRequest:
com.arsdigita.dispatcher.MultipartHttpServletRequest@18d702e
com.arsdigita.kernel.ACSObject:183: [com.arsdigita.cms.Folder:{id=183}]U
com.arsdigita.kernel.ACSObject:320:
[com.arsdigita.cms.contenttypes.Agenda:{id=320}]U
com.arsdigita.web.BaseApplicationServlet.application_id: 187
com.arsdigita.web.BaseDispatcher.dispatched: true
com.arsdigita.web.BaseServlet.request_url:
/ccm/content/admin/index.jsp?bbp.807.d=asc&g11n.enc=UTF-8&save=%C3%82%C2%A0%C3%82%C2%A0%C3%82%C2%A0Create%C3%82%C2%A0%C3%82%C2%A0%C3%82%C2%A0&bbp.945.sel=193&title=snrub&bbp.3.pane=0&bbp.i=d0.m.1.29.1&bbp.1049.d=asc&bbp.820.d=asc&bbp.20.ct=55&bbp.19.sel=183&language=en&bbp.s=28&bbp.689.stack=698&bbp.939.sel_context=%3Cdefault%3E&bbp.948.stack=956&bbp.1172.sel=55&bbp.73.sel=1&bbp.19.state=+183+&bbp.945.state=+193+&form.pageCreate=visited&name=snrub&bbp.69.ps=20
xmlMode: false

-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/content/admin/index.jsp
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: Cookies -*-*-*-
ad_user_login: 23!1174938200872!+KjtJxDPiJSg5uXtnsm6Jw== (expires: -1)
JSESSIONID: a_XDbvN-69K5 (expires: -1)
-*-*-*-*-*- End Error Report -*-*-*-*-*-
Comment 1 Jon Orris 2004-03-26 15:19:25 EST
Created attachment 98888 [details]
System log with persistence logging turned up

In addition to the CCM Error, see the earlier ERROR in the log:

2004-03-26 15:11:56,865 [004-0] ERROR rdbms.RDBMSEngine - update cms_items
set parent_id = ?
where cms_items.item_id = ?
java.sql.SQLException: ORA-01403: no data found
ORA-06512: at "JORRIS.CMS_ITEMS_ANCESTORS_UP_TRG", line 14
ORA-04088: error during execution of trigger
'JORRIS.CMS_ITEMS_ANCESTORS_UP_TRG'
Comment 2 Vadim Nasardinov 2004-03-26 16:06:32 EST
Created attachment 98892 [details]
see http://post-office.corp.redhat.com/archives/ccm-engineering-list/2004-March/msg00040.html

Jon,

Can you try the patch?	 I don't have an Oracle instance set up at home.
I'm pretty sure the problem is trivial and can be resolved by the attached
patch.

If the patch fails, then I'll go ahead and set up a 6.0 instance on my
Westford box, where I do have access to Oracle, and debug this ticket in
earnest.

If you adjust the first line of the patch to match your p4 layout, you should
be able to apply it by running

$ patch -p0 < cms-items-aux.patch
Comment 3 Jon Orris 2004-03-26 18:42:37 EST
This patch appears to have fixed the problem. Will test further.

Note You need to log in before you can comment on or make changes to this bug.