Bug 119230 - Installer crashes with 'Invalid modeline in file'
Installer crashes with 'Invalid modeline in file'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-26 14:56 EST by Ben Carlson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 17:47:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Carlson 2004-03-26 14:56:38 EST
Description of problem:

Anaconda crashes immediately after starting on my laptop: Dell C840
P4, 512MB, etc. Have no peripherals plugged in(had previous different
problems with wireless card, and USB mouse, both are unplugged).
I get the following message:

Running anaconda, the Fedora Core system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 678, in ?
    import xsetup
  File "/usr/lib/anaconda/xsetup.py", line 20, in ?
    import rhpl.xserver as xserver
  File "/usr/lib/python2.3/site-packages/rhpl/xserver.py", line 24, in ?
    import rhpl.monitor as monitor
  File "/usr/lib/python2.3/site-packages/rhpl/monitor.py", line 425, in ?
    read_modes("vesamodes")
  File "/usr/lib/python2.3/site-packages/rhpl/monitor.py", line 416,
in read_modes
    raise exceptions.StandardError("Invalid modeline in file: %s"%(line))
StandardError: Invalid modeline in file:
install exited abnormally
sending termination signals...done
sending kill signals...done



Version-Release number of selected component (if applicable):

Fedora Core 2 test 1

How reproducible:

every time, all install options (default, linux nofb, linux text,
linux text expert, etc)

Steps to Reproduce:
1. Attempt to install Fedora Core 2 test 1
2. fail in your attempt
3.
  
Actual results:
install crashes.

Expected results:
install succeeds


Additional info:
Comment 1 Jeremy Katz 2004-03-27 15:38:00 EST
Can you verify your media by booting with 'linux mediacheck'?  
Comment 2 Ben Carlson 2004-03-29 10:04:16 EST
Yup, verified the MD5sum, also ran the linux mediacheck on disc one.
Everything _seems_ like it should work, but something goofy is going on.
Comment 3 MP 2004-03-30 18:38:48 EST
I am also experiencing the exact same problem.  BUT - when I ran 
the 'mediacheck' it said my media was BAD.

I am able to boot, but when I get to the installer options (e.g. 
choice graphical or text install) no matter what I choice text or 
graphical - I received the following error:

Running anaconda, the Fedora Core system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 678, in ?
    import xsetup
  File "/usr/lib/anaconda/xsetup.py", line 20, in ?
    import rhpl.xserver as xserver
  File "/usr/lib/python2.3/site-packages/rhpl/xserver.py", line 24, 
in ?
    import rhpl.monitor as monitor
  File "/usr/lib/python2.3/site-packages/rhpl/monitor.py", line 425, 
in ?
    read_modes("vesamodes")
  File "/usr/lib/python2.3/site-packages/rhpl/monitor.py", line 416,
in read_modes
    raise exceptions.StandardError("Invalid modeline in file: %s"%
(line))

StandardError: Invalid modeline in file:
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
    /mnt/runtime done
    disabling /dev/loop0
...
you may safely reboot your system.


I am using the DVD iso provided at fedora.redhat.com.  My machine is 
a Dell Precision 420 (P3-800).  I have run Red Hat 7.2/8.0/9 Fedora 1 
all on this machine without any problems.

The DVD iso appears to be _exactly_ 2GB in size.  Is this correct???
Comment 4 Didier 2004-04-02 07:22:32 EST
WRT comment #3 :

This is due to missing largefile support in the FC1 version of gFTP
(2.0.14), and most probably other applications (mozilla, curl, wget,
...) : upgrade to at least gFTP 2.0.16 (provided in FC2t1).

Exact size of the FC2t2 DVD iso is 4306010112 bytes (md5
a70959924ac54e497a7143c6dc6b85c3).

Comment 5 gobbledegeek 2005-05-11 04:29:57 EDT
I have the same problem with fc3 custom cd, everything was fine and anaconda 
launced, util one day arbitarily, I cut a new cd and the problem appeared...

btw: What does largefile support have to with anaconda launching itself before 
any packages and os is installed?
Comment 6 gobbledegeek 2005-05-11 04:31:03 EDT
pardon the speels, bad keyboard..
Comment 7 gobbledegeek 2005-05-11 04:32:36 EDT
pardon the bad spells, bad keyboard..

I have the same problem with fc3 custom cd, everything was fine and anaconda 
*launched*, *until one day arbitarily (last week i.e), I cut a new cd and the 
problem appeared...

btw: What does largefile support have to with anaconda launching itself before 
any packages and os is installed?

I think the problem lies elsewhere and the bug should be reopened.


Note You need to log in before you can comment on or make changes to this bug.