This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 119245 - Missing tcl/tk header files
Missing tcl/tk header files
Status: CLOSED DUPLICATE of bug 108621
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcltk (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-26 21:10 EST by Blair Zajac
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Blair Zajac 2004-03-26 21:10:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I can't compile and link my programs on

Red Hat Enterprise Linux AS release 3 (Taroon Update 1)

that use tcl and tk.  Where'd they go???

% rpm -q --changelog tcl
....

* Fri Jul 04 2003 Jens Petersen <petersen@redhat.com> - 8.3.5-90

- split out devel files from tcl and tk into -devel subpackages 
(#90087)

It looks like these packages were simply forgotten.

Even this won't work:

% sudo up2date -u tcltk

Fetching package list for channel: rhel-i386-as-3...
########################################

Fetching Obsoletes list for channel: rhel-i386-as-3...

Fetching rpm headers...

Name                                    Version        Rel
----------------------------------------------------------

All packages are currently up to date


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to compile a program against tcl.
2.
3.
    

Actual Results:  Missing tcl.h.

Expected Results:  Compile just fine.

Additional info:
Comment 1 Jens Petersen 2004-03-29 07:54:30 EST
I believe tcl-devel will be made available on RHN before too long.

*** This bug has been marked as a duplicate of 108621 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.