Bug 119250 - PCMCIA hangs on boot
PCMCIA hangs on boot
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-27 01:29 EST by Adam Jones
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:22:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/pcmcia/network with bug fixed (1.01 KB, application/octet-stream)
2004-03-27 01:41 EST, Adam Jones
no flags Details
/etc/pcmcia/network with bug fixed (1.01 KB, application/octet-stream)
2004-03-27 01:42 EST, Adam Jones
no flags Details

  None (edit)
Description Adam Jones 2004-03-27 01:29:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
I'm using a Dell Inspiron 8200 with a TrueMobile wireless card
(pcmcia).  If the laptop looses power while the pcmcia card is active,
the system will hang on boot-up everytime afterward, regardless of
whether the pcmcia card is attached or not.
I'm not sure if this is the right place to post this or not, but I did
find the cause and solution and I would like to share it.

When the pcmcia service starts, it checks /var/lib/pcmcia/stab to see
if any cards are currently active and then tries to decativate them
with the cleanup() function in /etc/init.d/pcmcia.  Since the laptop
had lost power (and consequently did not cleared the stab file),
pcmcia services assume the card as still active and calls
"/etc/pcmcia/network stop".  This is where the hang actually occurs. 
It tries to to call ifdown ethX, which isn't initialized yet, and the
system hangs.

This can be easily fixed by changing the /etc/pcmcia/network file. 
I'm attaching a modified network script that checks to see if the
interface is actually up instead of simply assuming that it is.

--
Adam Jones

Version-Release number of selected component (if applicable):
kernel-pcmcia-cs-3.1.31-13

How reproducible:
Always

Steps to Reproduce:
1. activate pcmcia card
2. kill power (do not shutdown properly)
3. power on
    

Actual Results:  It will start to boot properly until it hits pcmcia
services.  Boot-up doesn't continue beyond this point.

Expected Results:  Boot-up have should coninute normally.

Additional info:
Comment 1 Adam Jones 2004-03-27 01:41:31 EST
Created attachment 98897 [details]
/etc/pcmcia/network with bug fixed

This is a modified version of /etc/pcmcia/network.  It checks to make sure that
interface is actually up before attempting to deactivate it.  This prevents the
PCMCIA service from hanging on start up after a loss of power while using a
pcmcia network card.
Comment 2 Adam Jones 2004-03-27 01:42:31 EST
Created attachment 98898 [details]
/etc/pcmcia/network with bug fixed

This is a modified version of /etc/pcmcia/network.  It checks to make sure that
interface is actually up before attempting to deactivate it.  This prevents the
PCMCIA service from hanging on start up after a loss of power while using a
pcmcia network card.
Comment 3 Adam Jones 2004-03-27 01:49:09 EST
Comment on attachment 98898 [details]
/etc/pcmcia/network with bug fixed

duplicate attachment
Comment 4 EJ Finneran 2004-11-20 02:54:52 EST
I'm not sure if this the exact same problem but it was similar.  My
comp froze and when I powered back on it stalled on PCMCIA
initialization.  All I had to do was boot into single mode and delete
/var/run/cardmgr.pid and it worked.

Note You need to log in before you can comment on or make changes to this bug.