Bug 119278 - Anaconda crashes after starting actual installation
Anaconda crashes after starting actual installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-28 16:12 EST by Richard Whitney
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump (67.43 KB, text/plain)
2004-03-28 16:13 EST, Richard Whitney
no flags Details

  None (edit)
Description Richard Whitney 2004-03-28 16:12:13 EST
Description of problem: Anaconda crashes after setup options are 
selected and actual installation starts

Version-Release number of selected component (if applicable):


How reproducible:  Everytime


Steps to Reproduce:
1.  Boot from Red Hat installation disk with graphic install option
2.  Select setup options
3.  Click 'OK' for actual installation to start
  
Actual results:  Anaconda dump produced


Expected results:  Installation contines


Additional info:  First few lines of dump follow:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 936, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 155, in 
renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 761, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 583, in doPreInstall
    method.mergeFullHeaders(id.hdList)
  File "/usr/lib/anaconda/image.py", line 50, in mergeFullHeaders
    hdlist.mergeFullHeaders(self.tree + "/RedHat/base/hdlist2")
  File "/usr/lib/anaconda/comps.py", line 180, in mergeFullHeaders
    rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
error: match tag mismatch
Comment 1 Richard Whitney 2004-03-28 16:13:32 EST
Created attachment 98911 [details]
Anaconda dump
Comment 2 Jeremy Katz 2004-03-29 11:51:13 EST
Could you verify your media according to the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?
Comment 3 Richard Whitney 2004-03-29 20:34:56 EST
Verified media as requested.  Also, I finally tried text (rather than 
graphic) install -- and that worked fine.....

Note You need to log in before you can comment on or make changes to this bug.