Bug 119280 - pppd[15407]: invalid numeric parameter 'yes' for idle option, ADSL Dial on Demand can not start
pppd[15407]: invalid numeric parameter 'yes' for idle option, ADSL Dial on De...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rp-pppoe (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Jay Turner
:
Depends On:
Blocks: 116727
  Show dependency treegraph
 
Reported: 2004-03-28 16:36 EST by Uwe Beck
Modified: 2015-01-07 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 22:49:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2004-03-28 16:36:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4) Gecko/20030922

Description of problem:
If you want use ADSL with Dial on Demand the pppd can not start.
pppd version 2.4.1 -> segmentation fault (see Bug #116927)
pppd version 2.4.2 (I build my own RPM) -> pppd[15407]: invalid
numeric parameter 'yes' for idle option
You can also see the false idle parameter in backtrace in Bug #116927.

The mistace is in /sbin/adsl-connect script.

/sbin/adsl-connect

# line 198 and after
# Backward config file compatibility
if test "$DEMAND" = "" ; then
       DEMAND=no
fi

if test "$DEMAND" = "no" ; then
       DEMAND=""
else
       DEMAND="demand persist idle $DEMAND \
10.112.112.112:10.112.112.113 ipcp-accept-remote ipcp-accept-local\
connect true noipdefault ktune"
fi

What is configured in the ADSL config file?
DEMAND=yes
CONNECT_TIMEOUT=60

Here is the mistace:
DEMAND="demand persist idle $DEMAND ....
$DEMAND has the value "yes".

I see this in /var/log/messages:
invalid numeric parameter 'yes' for idle option

The adsl-connect script do not use the CONNECT_TIMEOUT=60 and set this
value as the idle time in the variable DEMAND.

 

Version-Release number of selected component (if applicable):
rp-pppoe-3.5-4 and rp-pppoe-3.5-11 (fix for #114875 by Than)

How reproducible:
Always

Steps to Reproduce:
1. configure ADSL with Dial on Demand
2. start ADSL
3.
    

Actual Results:  pppd can not start because the idle parameter ist set
to "yes"

Expected Results:  idle $CONNECT_TIMEOUT should use

Additional info:
Comment 1 Ngo Than 2004-03-29 10:00:23 EST
many thank for your report. it's fixed in rp-pppoe-3.5-12, which is
available in rawhide on on people.redhat.com/than.

perhaps i will make errata soon.
Comment 2 Bernd Schmidt 2004-04-01 09:58:11 EST
Reopened so we can track this for QU3.
Comment 3 Uwe Beck 2004-04-01 15:08:23 EST
You mean QU2 for RHEL3?
If not, then we need the rp-pppoe-3.5-13 (yes there was another fix 
in this rpm from Than, I found an old mistace during test the first 
new rpm) as errata soon.
Comment 4 Ngo Than 2004-04-02 03:22:09 EST
it's for RHEL3 QU3
Comment 5 Ngo Than 2004-06-21 05:34:30 EDT
i have build rp-pppoe-3.5-4.1 for U3, which includes this patch.
Comment 6 Uwe Beck 2004-07-11 17:48:49 EDT
rp-pppoe-3.5-4.1 works correct and can distribute in U3.

Uwe
Comment 7 Jay Turner 2004-08-17 22:49:42 EDT
Closing out based on feedback from original reporter.
Comment 8 Jay Turner 2004-09-01 22:34:07 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-268.html

Note You need to log in before you can comment on or make changes to this bug.