Bug 1193306 - No validation on input storage size compute profile
Summary: No validation on input storage size compute profile
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources
Version: 6.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1223398 1365795 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-17 06:47 UTC by Fred van Zwieten
Modified: 2019-09-26 18:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-30 18:32:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 9418 0 None None None 2016-04-22 16:49:58 UTC

Description Fred van Zwieten 2015-02-17 06:47:13 UTC
Description of problem:
The "Size (G)" field has no validation. You can enter anything you like and it will be stored. I made the mistake to specify 8GB and not 8G. It accepted it, but it failed to provision. IT took quit some time to figure out what was wrong.

Version-Release number of selected component (if applicable):


How reproducible:
Enter anything you like in compute profile -> Storage -> Size.

Steps to Reproduce:
1.
2.
3.

Actual results:
Everything is accepted

Expected results:
Only positive integers should be accepted (the G in the field description "Size (G) already has the unit).

Additional info:

Comment 1 RHEL Program Management 2015-02-17 15:45:35 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-02-17 17:29:55 UTC
Created redmine issue http://projects.theforeman.org/issues/9418 from this bug

Comment 4 Bryan Kearney 2015-08-25 18:33:57 UTC
Upstream bug component is Compute Resources

Comment 5 Bryan Kearney 2016-08-10 19:06:34 UTC
Upstream bug component is Compute Resources - libvirt

Comment 6 Bryan Kearney 2016-08-10 20:07:31 UTC
Upstream bug component is Compute Resources

Comment 7 Bryan Kearney 2016-08-10 22:07:19 UTC
Upstream bug component is Compute Resources - libvirt

Comment 8 Ondřej Pražák 2016-08-18 09:51:28 UTC
*** Bug 1223398 has been marked as a duplicate of this bug. ***

Comment 9 Marek Hulan 2016-09-02 10:58:30 UTC
*** Bug 1365795 has been marked as a duplicate of this bug. ***

Comment 10 Bryan Kearney 2017-03-30 18:32:18 UTC
Thank you for your bug report. This bug is being tracked upstream, and will no longer be tracked in the downstream product. When the upstream issue is fixed, the next Satellite release will contain the fix. I am closing this out as deferred. If you feel this is not correct, please feel free to open with additional information. Thank you for your intrest in Satellite.


Note You need to log in before you can comment on or make changes to this bug.