Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1193390 - syntax warning in macro
Summary: syntax warning in macro
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: passenger
Version: rh-passenger40
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Jan Kaluža
QA Contact: Ondřej Pták
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-17 09:58 UTC by Ondřej Pták
Modified: 2015-06-04 08:05 UTC (History)
2 users (show)

Fixed In Version: rh-passenger40-2.0-5.el7 rh-passenger40-2.0-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-04 08:05:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1060 0 normal SHIPPED_LIVE new packages: rh-passenger40 2015-06-04 12:04:54 UTC

Description Ondřej Pták 2015-02-17 09:58:03 UTC
Description of problem:
If I install rh-passenger40-scldevel on rhel-7, I got these warnings every time I use yum/rpm:
warning: Macro %scl_rh needs whitespace before body
warning: Macro %scl_prefix_rh needs whitespace before body

Version-Release number of selected component (if applicable):
rh-passenger40-scldevel-2.0-4.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. yum install -y rh-passenger40-scldevel
2. rpm -q rpm

Actual results:
warning: Macro %scl_rh needs whitespace before body
warning: Macro %scl_prefix_rh needs whitespace before body
rpm-4.11.1-16.el7.x86_64

Expected results:
rpm-4.11.1-16.el7.x86_64

Additional info:
This error didn't occur on rhel-6

Comment 4 Ondřej Pták 2015-04-02 14:54:51 UTC
No more problem with this macro (with this error, majority of automated tests was affected)

Comment 6 errata-xmlrpc 2015-06-04 08:05:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1060.html


Note You need to log in before you can comment on or make changes to this bug.