Bug 1193518 - Incorrect ABI version of libgnat
Summary: Incorrect ABI version of libgnat
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gprbuild
Version: 22
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Pavel Zhukov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-17 14:02 UTC by Pavel Zhukov
Modified: 2015-04-30 11:38 UTC (History)
6 users (show)

Fixed In Version: gprbuild-2014-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-30 11:38:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Pavel Zhukov 2015-02-17 14:02:36 UTC
Description of problem:
libgnat-5.so should be libgnat-5.0.so

Version-Release number of selected component (if applicable):
gcc                      x86_64   5.0.0-0.14.fc23   

How reproducible:
100%

Steps to Reproduce:
Try to link program with gnat (gnarl)

Actual results:
/usr/bin/ld: cannot find -lgnarl-5.0
/usr/bin/ld: cannot find -lgnat-5.0

Additional info:

Comment 1 Jakub Jelinek 2015-02-17 14:04:14 UTC
Of course not.  GCC changed versioning scheme, so it should be 5 and not 5.0.

Comment 2 Pavel Zhukov 2015-02-17 14:19:27 UTC
Thank you for clarification.
Reassigning to gprbuild (me) then

Comment 3 Pavel Zhukov 2015-03-29 18:47:43 UTC
*** Bug 1152496 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2015-03-29 19:19:40 UTC
gprbuild-2014-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gprbuild-2014-2.fc22

Comment 5 Fedora Update System 2015-03-31 22:01:01 UTC
Package gprbuild-2014-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gprbuild-2014-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5194/gprbuild-2014-2.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-04-30 11:38:09 UTC
gprbuild-2014-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.