This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 119416 - passwd.spec should 'BuildRequires: libselinux-devel'
passwd.spec should 'BuildRequires: libselinux-devel'
Status: CLOSED DUPLICATE of bug 123750
Product: Fedora
Classification: Fedora
Component: passwd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 03:26 EST by Kir Kolyshkin
Modified: 2013-07-02 18:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kir Kolyshkin 2004-03-30 03:26:42 EST
Description of problem:
'BuildRequires: libselinux-devel' is missing from passwd.spec

Version-Release number of selected component (if applicable):
passwd-0.68-8.1.src.rpm

Steps to Reproduce:
Make sure there's no libselinux-devel and try rebuilding passwd:

  [kir@kir kir]$ LANG=C rpmbuild --rebuild passwd-0.68-8.1.src.rpm
Installing passwd-0.68-8.1.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.92689
+ umask 022
+ cd /home/kir/src//BUILD
+ cd /home/kir/src/BUILD
+ rm -rf passwd-0.68
+ /usr/bin/gzip -dc /home/kir/src/SOURCES/passwd-0.68-8.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd passwd-0.68
++ /usr/bin/id -u
+ '[' 501 = 0 ']'
++ /usr/bin/id -u
+ '[' 501 = 0 ']'
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.92689
+ umask 022
+ cd /home/kir/src//BUILD
+ cd passwd-0.68
+ make DEBUG= 'RPM_OPT_FLAGS=-O2 -g -march=i386 -mcpu=i686'
WITH_SELINUX=yes
echo "static char version_date[] = \"" `date +%D` "\";" > date.h
gcc -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -O2 -g
-march=i386 -mcpu=i686 -Wall -D_GNU_SOURCE  -DLIBUSER -DWITH_SELINUX
-c -o passwd.o passwd.c
passwd.c:55:29: selinux/selinux.h: No such file or directory
passwd.c:56:29: selinux/context.h: No such file or directory
passwd.c:57:36: selinux/av_permissions.h: No such file or directory
make: *** [passwd.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.92689 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.92689 (%build)
Comment 1 Jindrich Novy 2004-08-23 08:11:34 EDT

*** This bug has been marked as a duplicate of 123750 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.