Bug 119425 - php function ldap_start_tls undefined
Summary: php function ldap_start_tls undefined
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 121711 (view as bug list)
Depends On:
Blocks: 116727
TreeView+ depends on / blocked
 
Reported: 2004-03-30 12:27 UTC by Nicolai van der Smagt
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 03:22:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:169 normal SHIPPED_LIVE Updated php packages available 2004-05-11 04:00:00 UTC

Description Nicolai van der Smagt 2004-03-30 12:27:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040215 Firefox/0.8

Description of problem:
Fatal error: Call to undefined function: ldap_start_tls() in
/var/www/html/test.php

Though PHP is compiled with openssl and openldap, somehow LDAP start
TLS function is missing.

Version-Release number of selected component (if applicable):
php-4.3.2-8.ent

How reproducible:
Always

Steps to Reproduce:
1. Create test.php in your webroot:
<?
$ds = ldap_connect($LDAP_SERVER,$LDAP_PORT);
if (!ldap_start_tls($ds)) {
    fatal_error("Ldap_start_tls failed");
}
?>
2 Retrieve test.php in your browser


Actual Results:  Fatal error: Call to undefined function:
ldap_start_tls() in /var/www/html/test.php

Expected Results:  A LDAP connection, secured by TLS should've been made.

Additional info:

Comment 1 Joe Orton 2004-03-30 13:33:02 UTC
Thanks for the report.  Yes, this is a bug in the php 4.3.2 configure
script, which should detect the presence of the function in libldap
but fails.

Comment 2 Joe Orton 2004-04-16 13:18:20 UTC
Updated PHP packages which should fix this issue are now available for
testing purposes from the following location:
http://people.redhat.com/jorton/Taroon-php/



Comment 3 Joe Orton 2004-04-28 18:11:37 UTC
*** Bug 121711 has been marked as a duplicate of this bug. ***

Comment 4 John Flanagan 2004-05-12 03:22:42 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-169.html



Note You need to log in before you can comment on or make changes to this bug.