Bug 119445 - Could not find slib/require.scm after installing gnucash-1.8.8-5
Summary: Could not find slib/require.scm after installing gnucash-1.8.8-5
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-30 16:31 UTC by Jan Pazdziora
Modified: 2014-03-17 02:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-30 22:53:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace when running gnucash from random directory (69.97 KB, text/plain)
2004-03-30 16:52 UTC, Jan Pazdziora
no flags Details
Strace running gnucash from /usr/share/umb-scheme (63.34 KB, text/plain)
2004-03-30 16:54 UTC, Jan Pazdziora
no flags Details

Description Jan Pazdziora 2004-03-30 16:31:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Galeon/1.3.14

Description of problem:
After upgrading to Fedora Core 2 Test 2's gnucash and
dependents, running gnucash fails with

ERROR: Could not find slib/require.scm in  ("/usr/share/guile"
"/usr/share/gnucash/guile-modules" "/usr/share/gnucash/scm" ""
"/usr/share/guile/site" "/usr/share/guile/1.6" "/usr/share/guile" ".")

Version-Release number of selected component (if applicable):
gnucash-1.8.8-5

How reproducible:
Always

Steps to Reproduce:
1. run gnucash
    

Additional info:

The packages that I have installed for 1.8.8-5 are
gnucash-1.8.8-5.i386.rpm guile-1.6.4-9.2.1.i386.rpm
g-wrap-1.3.4-5.1.i386.rpm umb-scheme-3.2-32.i386.rpm

Comment 1 Bill Nottingham 2004-03-30 16:37:27 UTC
Works for me. What does 'rpm -V' of the various packages say?

Comment 2 Jan Pazdziora 2004-03-30 16:45:14 UTC
rpm -V guile umb-scheme g-wrap gnucash

is clean, no errors. Google finds a couple of hits related to
Guile, Scheme and slib. But nothing is really fitting.

What other packages should I check?

BTW, the slib/require.scm is in /usr/share/umb-scheme/slib/require.scm
here. If I cd /usr/share/umb-scheme (as the error message says it also
looks in "."), the error message changes to

$ cd /usr/share/umb-scheme/
$ pwd
/usr/share/umb-scheme
$ gnucash
ERROR: In procedure substring:
ERROR: Argument 3 out of range: -1

The file is

$ ls -la /data/usr_share/umb-scheme/slib/require.scm
-rw-r--r--    1 root     root        11469 Nov 27  2002
/data/usr_share/umb-scheme/slib/require.scm

-- how about yours?



Comment 3 Bill Nottingham 2004-03-30 16:49:33 UTC
Can you attach the strace of running gnucash?

Comment 4 Jan Pazdziora 2004-03-30 16:52:41 UTC
Created attachment 98971 [details]
Strace when running gnucash from random directory

The first attachment is when the ERROR: Could not find slib/require.scm in 
("/usr/share/guile" "/usr/share/gnucash/guile-modules" "/usr/share/gnucash/scm"
"" "/usr/share/guile/site" "/usr/share/guile/1.6" "/usr/share/guile" ".")
error shows.

Comment 5 Jan Pazdziora 2004-03-30 16:54:09 UTC
Created attachment 98972 [details]
Strace running gnucash from /usr/share/umb-scheme

The second shows gnucash running from /usr/share/umb-scheme directory,
where the slib/require.scm resides.

Comment 6 Bill Nottingham 2004-03-30 16:55:30 UTC
You don't have a /usr/share/guile/slib/require.scm?

Comment 7 Bill Nottingham 2004-03-30 16:56:17 UTC
More exactly:

lrwxrwxrwx    1 root    root               27 Mar  4 09:49
/usr/share/guile/slib -> ../../share/umb-scheme/slib
lrwxrwxrwx    1 root    root               30 Mar  4 09:49
/usr/share/guile/slibcat -> ../../share/umb-scheme/slibcat

Do these not resolve in your layout?

Comment 8 Jan Pazdziora 2004-03-30 17:08:28 UTC
That did the trick. The links were there but since my /usr/share is on
a different filesystem, they did not resolve to the proper target.
Changing them to absolute links makes gnucash behave well.

Thank you for your prompt help.

Comment 9 Bill Nottingham 2004-03-30 22:53:49 UTC
No problem. Closing as I believe this is working as expected.


Note You need to log in before you can comment on or make changes to this bug.