Bug 119469 - Pango-devl-1.2.5-4 has a packaging error causing it to misrepresent which repository it belongs in
Pango-devl-1.2.5-4 has a packaging error causing it to misrepresent which rep...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 14:40 EST by Alan Grossfield
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 14:35:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Grossfield 2004-03-30 14:40:12 EST
Description of problem:
pango-devel-1.2.5-4 rpm has mislabelled group, causing yum-based upgrades to fail
Version-Release number of selected component (if applicable):
1.2.5-4

How reproducible:
Using a standard Fedora Core 1 machine which does not have the newest pango-devel, 
attempt to update the machine using 

yum update


  
Actual results:
Yum will fail on the download step, after downloading the header file.  From what I can tell, 
the header leads it to expect the rpm to be under base instead of updates.  I no longer 
have the screen snap, but it told me that the rpm couldn't be downloaded.  After verifying 
that it was in fact present, I ran

% yum check-update
Gathering header information file(s) from server(s)
Server: Dasher base
Server: Dasher
Finding updated packages
Downloading needed headers
Name                                Arch   Version                  Repo
--------------------------------------------------------------------------------
ghostscript                         i386   7.07-15.2                updates-released
hpijs                               i386   1.5-4.2                  updates-released
openssl                             i686   0.9.7a-33.10             updates-released
openssl-devel                       i386   0.9.7a-33.10             updates-released
pango-devel                         i386   1.2.5-4                  base
perl                                i386   3:5.8.3-16               updates-released
xmms                                i386   1:1.2.10-1.p             updates-released
xmms-skins                          i386   1:1.2.10-1.p             updates-released

As you can see, the pango-devel rpm is labelled as being in a different (incorrect) 
repository, which is why yum couldn't find it to download.  Manually installing the rpm fixed 
the problem, but the packaging error will mess things up for people who use yum.

Expected results:
Yum should have worked cleanly.

Additional info:
Comment 1 Owen Taylor 2004-03-30 14:45:39 EST
Don't think this has anything to do with pango per-se.
Comment 2 Jeff Johnson 2004-04-07 12:52:02 EDT
This is a comps problem.
Comment 3 Bill Nottingham 2004-04-07 15:29:22 EDT
Can you attach your /etc/yum.conf? Are you running as root?
Comment 4 Seth Vidal 2004-04-07 15:31:21 EDT
and a nice addition would be attaching:
/var/cache/yum/base/header.info
Comment 5 Seth Vidal 2004-11-01 14:35:48 EST
Reopen if this is still a problem.

Note You need to log in before you can comment on or make changes to this bug.