Bug 1194712 - Uploading to multidatacenter iso domain is not supported
Summary: Uploading to multidatacenter iso domain is not supported
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-iso-uploader
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.2
Assignee: Sandro Bonazzola
QA Contact: Elad
URL:
Whiteboard: integration
Depends On:
Blocks: 1193058
TreeView+ depends on / blocked
 
Reported: 2015-02-20 15:33 UTC by David Caro
Modified: 2016-06-26 23:50 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-29 06:19:56 UTC
oVirt Team: ---
amureini: needinfo+
sbonazzo: needinfo+


Attachments (Terms of Use)

Description David Caro 2015-02-20 15:33:04 UTC
Description of problem:
When uploading an iso to a domain that is enabled in multiple datacenters, you get an error saying that the query produces ambiguous results.

Version-Release number of selected component (if applicable):
3.5.0

How reproducible:
Setup a multidatacenter domain and try to upload an iso to it

Steps to Reproduce:
1.Setup a multidatacenter domain
2.upload an iso to it
3.

Actual results:
Failed to upload imabe due to ambiguous query

Expected results:
Image uploaded

Additional info:


Here is the output

root@engine-phx ~]# ovirt-iso-uploader -i "ISOS" upload /home/dcaro/Fedora-Server-netinst-x86_64-21.iso 
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ERROR: [ERROR]::Used query (name=ISOS) produces ambiguous results.
INFO: Use the -h option to see usage.
[root@engine-phx ~]# ovirt-iso-uploader list
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ISO Storage Domain Name   | Datacenter                | ISO Domain Status
ISOS                      | Default                   | active
ISOS                      | Jenkins                   | active
[root@engine-phx ~]# ovirt-iso-uploader -i "Jenkins" upload /home/dcaro/Fedora-Server-netinst-x86_64-21.iso 
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ERROR: The Jenkins storage domain supplied is not of type ISO
INFO: Use the -h option to see usage.
[root@engine-phx ~]# 


Some info about the installed packages

[root@engine-phx ~]# rpm -qa | grep  ovirt
ovirt-engine-setup-base-3.5.0.1-1.fc19.noarch
ovirt-engine-restapi-3.5.0.1-1.fc19.noarch
ovirt-release35-002-1.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.0.1-1.fc19.noarch
ovirt-engine-websocket-proxy-3.5.0.1-1.fc19.noarch
ovirt-engine-webadmin-portal-3.5.0.1-1.fc19.noarch
ovirt-host-deploy-1.3.0-1.fc19.noarch
ovirt-iso-uploader-3.5.0-1.fc19.noarch
ovirt-engine-tools-3.5.0.1-1.fc19.noarch
ovirt-engine-backend-3.5.0.1-1.fc19.noarch
ovirt-release-11.2.0-1.noarch
ovirt-host-deploy-java-1.3.0-1.fc19.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.5.0.1-1.fc19.noarch
ovirt-engine-lib-3.5.0.1-1.fc19.noarch
ovirt-engine-3.5.0.1-1.fc19.noarch
ovirt-host-deploy-java-1.2.2-1.fc19.noarch
ovirt-engine-extensions-api-impl-3.5.0.1-1.fc19.noarch
ovirt-image-uploader-3.5.0-1.fc19.noarch
ovirt-engine-dbscripts-3.5.0.1-1.fc19.noarch
ovirt-engine-setup-3.5.0.1-1.fc19.noarch
ovirt-host-deploy-1.2.2-1.fc19.noarch
ovirt-release34-1.0.2-1.noarch
ovirt-engine-cli-3.5.0.5-1.fc19.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.0.1-1.fc19.noarch
ovirt-engine-sdk-python-3.5.0.8-1.fc19.noarch
ovirt-engine-userportal-3.5.0.1-1.fc19.noarch

Comment 1 David Caro 2015-02-20 15:43:26 UTC
As a workaround you can detach the extra datacenter from the storage domain, upload the image and reattach (for future reference):

* Go to storage tab
* select the ISO domain
* Go to 'data center' in the lower tabs
* Select one of them
* click maintenance
* when finished, select it again and click detach
* upload the iso
* when finished, in the same tab as before click attach and select the domain you detached

Comment 2 Yaniv Lavi 2015-02-26 08:30:49 UTC
Sandro, what is the scope of this fix?
Allon, is this a new feature in 3.5?

Comment 3 Allon Mureinik 2015-02-26 09:27:50 UTC
(In reply to Yaniv Dary from comment #2)
> Allon, is this a new feature in 3.5?
This isn't a new feature - attaching an ISO to multiple DCs was possible since 3.1, at least.
(This does not mean, however, that this bug is necessarily so old - this might be a new bug introduced much later, but Sandro will have to answer that - I'm not that familiar with the iso uploader).

Comment 4 Sandro Bonazzola 2015-02-26 12:57:30 UTC
I'm not able to reproduce with 3.5.3 snapshot code:

# engine-iso-uploader list
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ISO Storage Domain Name   | Datacenter                | ISO Domain Status
iso_shared                | Default                   | active
iso_shared                | local_datacenter          | active

# engine-iso-uploader -i iso_shared upload test.iso
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
Uploading, please wait...
INFO: Start uploading test.iso 
INFO: test.iso uploaded successfully

# rpm -qa | grep  ovirt
ovirt-engine-webadmin-portal-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-setup-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-setup-plugin-allinone-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-release35-002-1.noarch
ovirt-engine-cli-3.5.0.6-0.1.20150205.gitcf7f1a1.el7.centos.noarch
ovirt-engine-lib-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-websocket-proxy-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-release35-snapshot-002-1.noarch
ovirt-engine-sdk-python-3.5.1.1-0.1.20150121.git2851a13.el7.centos.noarch
ovirt-iso-uploader-3.5.2-0.0.master.20150202155334.git97fe988.el7.noarch
ovirt-engine-tools-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-userportal-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-restapi-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-backend-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-host-deploy-offline-1.4.0-0.0.master.20150223203338.gitd379f43.el7.x86_64
ovirt-host-deploy-1.4.0-0.0.master.20150223203338.gitd379f43.el7.noarch
sos-3.2-0.2.el7.ovirt.noarch
ovirt-engine-jboss-as-7.1.1-1.el7.x86_64
ovirt-engine-setup-plugin-websocket-proxy-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-host-deploy-java-1.4.0-0.0.master.20150223203338.gitd379f43.el7.noarch
ovirt-engine-dbscripts-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-image-uploader-3.5.2-0.0.master.20150120075231.git214130b.el7.noarch
ovirt-engine-extensions-api-impl-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-setup-base-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.3-0.0.master.20150225124849.git6c3a6f3.el7.centos.noarch

Moving to QA for testing with 3.5.2 RC1.

Comment 5 Sandro Bonazzola 2015-03-02 14:06:10 UTC
David, can you confirm it's working also on your instance?

Comment 6 David Caro 2015-03-16 14:02:04 UTC
I can't test it on the production instance

Comment 7 Elad 2015-03-18 14:36:51 UTC
Uploading an ISO file to an ISO domain, using ovirt-iso-uploader, while the domain is attached (active) to more than 1 DCs, succeeds.

Verified using rhev 3.5.1 vt14

Comment 8 Eyal Edri 2015-04-29 06:19:56 UTC
ovirt 3.5.2 was GA'd. closing current release.


Note You need to log in before you can comment on or make changes to this bug.