Bug 119504 - Java development doesn't work at all with IBM SDK 1.4.1 from Extras disc
Java development doesn't work at all with IBM SDK 1.4.1 from Extras disc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: JDT (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 18:04 EST by Ronald Cole
Modified: 2007-04-18 13:05 EDT (History)
0 users

See Also:
Fixed In Version: RHEL3ES2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 17:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Cole 2004-03-30 18:04:58 EST
Description of problem:
According to the "Workbench User Guide, Red Hat Release Notes" that
come bundled with Eclipse, IBM SDK 1.4.1 is a recommended JRE.  After
installing IBMJava2-JRE and IBMJava2-SDK from the Extras disc and
configuring Eclipse to use the newly installed JRE, any and all
attempts to compile and run a Java Class fail.

Version-Release number of selected component (if applicable):
eclipse-2.1.1-4
IBMJava2-SDK-1.4.1-9
IBMJava2-JRE-1.4.1-8

How reproducible:
Completely

Steps to Reproduce:
1. Window > Preferences
2. Java > Installed JREs
3. Search > "/opt/IBMJava2-141" > OK
4. OK
5. Window > Open Perspective > Java
6. [New Java Product] toolbar button
7. Enter the Project Name: com.ibm.lab.usingjdt.helloworld
8. [Finish] button
9. [New Java Class] toolbar button > Class
10. Enter the Class Name: HelloWorld
11. Select the main method stub creation.
12. Unselect the inherited abstract methods creation
13. [Finish] button
  
Actual results:
* The project was not built since its classpath is incomplete.  Cannot
  find the class file for java.lang.Object.  Fix the classpath and
  then try rebuilding this project.
* This compilation unit indirectly references the missing type
  java.lang.Object (typically some required class file is referencing
  a type outside the classpath)

Expected results:
Application to compile and run without error.

Additional info:
This is probably caused by bugzilla bug #114354, since said release
notes concur that the IBM JRE worked as expected in the Beta version
of Taroon.
Comment 1 Jeremy Handcock 2004-03-30 18:17:35 EST
Moving to Red Hat Developer Suite product for review.
Comment 2 Jeremy Handcock 2004-04-21 10:49:27 EDT
I can't seem to reproduce this problem on an up2date RHEL3 box with
the package versions that you mention.

Are you still seeing this problem, given the resolution to bug #114354?
Comment 3 Ronald Cole 2004-04-21 13:16:54 EDT
Yes.  I have two installed JRE's: IBM's and Sun's.  Both installed the
same way.  When I select the Sun JRE and Eclipse rebuilds everything,
there are no errors in the task window.  When I select the IBM JRE and
Eclipse attempts to rebuild everything, the result is as described
above: two errors in the task window.
Comment 4 Jeremy Handcock 2004-04-23 15:25:22 EDT
I see what's happening here.  When you do:

1. Window -> Preferences
2. Java -> Installed JREs
3. Search -> "/opt/IBMJava2-141" > OK

..., Eclipse searches and incorrectly identifies /opt/IBMJava2-141/jre
as the path to the JRE, when it should be just /opt/IBMJava2-141.  As
a quick workaround:

1. Window -> Preferences
2. Java -> Installed JREs
3. Add... -> JRE home directory: /opt/IBMJava2-141
Comment 5 Ronald Cole 2004-04-23 20:49:38 EDT
Sorry, but that workaround results in the same errors in the Tasks
window for me.  Does this really work for you?  I'd load RHEL3 on
another computer to test your claim that it does, but updating it
won't be easy for me without buying another RHN subscription.
Comment 6 Ronald Cole 2004-04-29 18:17:52 EDT
Well, I don't believe your claim that it works for you on a fully
updated RHEL3 with IBMJava2-JRE-1.4.1-8, so I've reopened bug #114354.
 Here's why:

With IBMJava2-JRE-1.4.1-8 and IBMJava2-SDK-1.4.1-9 from the "Extras"
disc of RHEL3, "eclipse -vm /usr/IBMJava2-141/bin/java" tosses up an
error window faster than Kerry can throw his 'Nam medals.
$ java -version
java version "1.4.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
Classic VM (build 1.4.1, J2RE 1.4.1 IBM build cxia321411-20030917 (JIT
enabled: jitc))

Now, if I install IBMJava2-SDK-1.4.1-2.0.i386.rpm from IBM's web site,
"eclipse -vm /usr/IBMJava2-141.works/bin/java" comes up as expected
with no errors in the task window!
$ java -version
java version "1.4.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
Classic VM (build 1.4.1, J2RE 1.4.1 IBM build cxia321411-20040301 (JIT
enabled: jitc))

Note You need to log in before you can comment on or make changes to this bug.