Bug 119509 - The program 'gftp-gtk' received an X Window System error
The program 'gftp-gtk' received an X Window System error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gftp (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 18:40 EST by JF
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-31 22:55:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JF 2004-03-30 18:40:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
After ssh -X into my Fedora box from a Windows XP machine running the
latest Cygwin/X server, when I attempt to launch gftp in the xterm
gftp crashes with the following error after attempting to click a menu:

The program 'gftp-gtk' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 3400 error_code 3 request_code 38 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)

Could this be because I have no X server running on the Fedora box?

Version-Release number of selected component (if applicable):
2.0.14

How reproducible:
Sometimes

Steps to Reproduce:
1. Login to a Fedora box using ssh -X (no X server running)
2. Attempt to launch gftp
3. Click a menu in gftp and watch the crash

This may be a Cygwin/X only bug because I have used gftp remotely many
times without problems with the OS/X XFree86 and with other Linux
boxes. Though now it seems the crash doesn't happen everytime I use
gftp through Cygwin/X.
    

Additional info:
Comment 1 JF 2004-03-31 22:55:58 EST
Sorry, I don't think this is a bug in gftp after all. I read on the
Cygwin/X mailing list that openssh 3.8 has a new config directive
called ForwardX11Trusted, if one sets this to yes, the crash seems to
dissapear and the program runs much faster to boot. To use this one
would connect to the remote box using the command ssh -X -Y user@host,
this enables X11 Forwarding and Trusted X11 Forwarding (new in OpenSSH
3.8, I think).  See man ssh_config for more details.

Note You need to log in before you can comment on or make changes to this bug.