Bug 119514 - segfault during up2date
Summary: segfault during up2date
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-31 00:32 UTC by Graham Leggett
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-02 18:02:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Graham Leggett 2004-03-31 00:32:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
Run up2date, the following happens:

[root@dungeon root]# up2date -u
 
Fetching package list for channel: rhel-i386-es-3...
########################################
 
Fetching package list for channel: rhel-i386-es-3-extras...
########################################
 
Fetching Obsoletes list for channel: rhel-i386-es-3...
 
Fetching Obsoletes list for channel: rhel-i386-es-3-extras...
 
Fetching rpm headers...
Segmentation fault

Running up2date through strace, the following happens:

write(1, "\nFetching rpm headers...", 24
Fetching rpm headers...) = 24
write(1, "\n", 1
)                       = 1
stat64("/var/spool/up2date/ethereal-0.10.3-0.30E.1.i386.hdr",
{st_mode=S_IFREG|0644, st_size=8192, ...}) = 0
access("/var/spool/up2date/ethereal-0.10.3-0.30E.1.i386.hdr", R_OK) = 0
stat64("/var/spool/up2date/ethereal-0.10.3-0.30E.1.i386.hdr",
{st_mode=S_IFREG|0644, st_size=8192, ...}) = 0
access("/var/spool/up2date/ethereal-0.10.3-0.30E.1.i386.hdr", R_OK) = 0
open("/var/spool/up2date/ethereal-0.10.3-0.30E.1.i386.hdr",
O_RDONLY|O_LARGEFILE) = 6
fstat64(6, {st_mode=S_IFREG|0644, st_size=8192, ...}) = 0
_llseek(6, 0, [0], SEEK_CUR)            = 0
fstat64(6, {st_mode=S_IFREG|0644, st_size=8192, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x40016000
_llseek(6, 0, [0], SEEK_CUR)            = 0
read(6, "\0\0\0@\0\0N\240\0\0\0?\0\0\0\7\0\0M\314\0\0\0\20\0\0\0"...,
8192) = 8192
read(6, "", 4096)                       = 0
close(6)                                = 0
munmap(0x40016000, 4096)                = 0
mremap(0x84774dd, 4294967287, 4096, MREMAP_MAYMOVE) = -1 EINVAL
(Invalid argument)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

The file it is trying to access / download / whatever is as follows:

[root@dungeon root]# ls -al
/var/spool/up2date/ethereal-0.10.3-0.30E.1.i386.hdr
-rw-r--r--    1 root     root         8192 Mar 30 21:45
/var/spool/up2date/ethereal-0.10.3-0.30E.1.i386.hdr


Version-Release number of selected component (if applicable):
up2date-4.2.5-1

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:

Comment 1 Adrian Likins 2004-03-31 22:31:30 UTC
looks like something in rpm, assigning there

Comment 2 Jeff Johnson 2004-04-02 18:02:47 UTC
Removing the damaged /var/spool/up2date/ethereal-0.10.3-0.30E.1.i386.hdr

should fix the problem.

Reopen this bug if not.

Comment 3 Graham Leggett 2004-04-02 19:39:36 UTC
Removing the file works around the problem, but does not fix it.
Up2date should not segfault, regardless of the state of brokenness of
a file.



Note You need to log in before you can comment on or make changes to this bug.