Bug 119516 - (IDE)ide-scsi still needed for CD-R slave with DVD master
(IDE)ide-scsi still needed for CD-R slave with DVD master
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 20:23 EST by John Reiser
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 01:01:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages errors without hdd=ide-scsi (22.68 KB, text/plain)
2004-03-30 20:24 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2004-03-30 20:23:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
These two devices don't work together unless booted with "hdd=ide-scsi":
-
class: CDROM
bus: IDE
detached: 0
device: hdc
driver: ignore
desc: "LG DVD-ROM DRD-8160B"
-
class: CDROM
bus: IDE
detached: 0
device: hdd
driver: ignore
desc: "SONY CD-RW CRX175E2"
-


Version-Release number of selected component (if applicable):
kernel-2.6.4-1.298

How reproducible:
Always

Steps to Reproduce:
1.Boot without "hdd=ide-scsi".
2.Look in /var/log/messages for errors+reset during ide device probe.
3.Boot with "hdd=ide-scsi".
4.Look in /var/log/messages for no error in ide device probe.
    

Actual Results:  Without hdd=ide-scsi: error messages during ide
device probe, as in attachment.  With hdd=ide-scsi: no errors reported.

Expected Results:  No errors in either case; no need for hdd=ide-scsi.


Additional info:

When booted with hdd=ide-scsi:
# cd /proc/ide
# cat hdc/settings
name                    value           min             max          
  mode
----                    -----           ---             ---          
  ----
current_speed           66              0               70              rw
dsc_overlap             1               0               1               rw
ide-scsi                0               0               1               rw
init_speed              66              0               70              rw
io_32bit                0               0               3               rw
keepsettings            0               0               1               rw
nice1                   1               0               1               rw
number                  2               0               3               rw
pio_mode                write-only      0               255             w
unmaskirq               0               0               1               rw
using_dma               1               0               1               rw
# cat hdd/settings
name                    value           min             max          
  mode
----                    -----           ---             ---          
  ----
current_speed           34              0               70              rw
ide-scsi                0               0               1               rw
init_speed              34              0               70              rw
io_32bit                0               0               3               rw
keepsettings            0               0               1               rw
nice1                   1               0               1               rw
number                  3               0               3               rw
pio_mode                write-only      0               255             w
unmaskirq               0               0               1               rw
using_dma               1               0               1               rw
# 
-----

BIOS IDE device detection says hdc(DVD) is UDMA33, and hdd(CD-R) is mwDMA.
Comment 1 John Reiser 2004-03-30 20:24:49 EST
Created attachment 98985 [details]
/var/log/messages errors without hdd=ide-scsi
Comment 2 Alan Cox 2004-05-03 11:10:53 EDT
PIO v DMA problem at a first guess but very strange indeed.
Comment 3 John Reiser 2004-05-03 11:48:45 EDT
Motherboard chipset is i845 (piix ICH2), whose IDE timings seem to be
non-adjustable once the ATA mode is set.  [How can I force a change
from PIO mode 4 (mwDMA2) to PIO mode 3 (mwDMA1)?  Or set the
address-setup time to 120ns absolutely, like on VIA chipsets?]

Workaround: boot with a CD-ROM or CD-RW [either blank or already
recorded] in hdd (SONY CRX175E2).  Then there are no errors reported
in /var/log/messages, even without hdd=ide-scsi, and burning a CD-RW
works using "cdrecord dev=/dev/hdd ..."  So it looks like a
device-specific problem [slow or bad SONY].
Comment 4 Dave Jones 2004-12-08 00:51:54 EST
any better with the 2.6.9 update ?
Comment 5 John Reiser 2004-12-08 15:13:18 EST
Hardware has changed, the problem does not occur with new hardware under
kernel-2.6.9-1.6_FC2.  The old hardware is unavailable for testing. 
Configuration is now:
hdc: PLEXTOR DVDR PX-712A, ATAPI CD/DVD-ROM drive  [replaces LG DVD-ROM DRD-8160B]
hdd: SONY CD-RW CRX175E2, ATAPI CD/DVD-ROM drive  [same as before]
In addition to software updates, this could cast some doubt on the hardware
behavior of the old LG DVD-ROM when used as master with a slave present.

Note You need to log in before you can comment on or make changes to this bug.