Bug 119531 - selinux errors occur when using rpm
selinux errors occur when using rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 23:14 EST by mark
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-10 09:09:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark 2004-03-30 23:14:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
i always get these three selinux error messages when installing
packages (regardless of the package):

e.g.

[root@markf78 home]# rpm -ivh j2*
/etc/security/selinux/file_contexts:  invalid context
system_u:object_r:canna_var_lib_t on line number 629
/etc/security/selinux/file_contexts:  invalid context
system_u:object_r:screensaver_exec_t on line number 1463
Preparing...               
########################################### [100%]
   1:j2sdk                 
########################################### [ 50%]
warning: setexeccon(root:staff_r:rpm_script_t) fails from context
"root:staff_r:staff_t": Invalid argument
Continuing ...
   2:j2re                  
########################################### [100%]
warning: setexeccon(root:staff_r:rpm_script_t) fails from context
"root:staff_r:staff_t": Invalid argument
Continuing ...

i'm running in permissive mode so they aren't affecting me that i know
of but i'm sure people in enforcing mode will be facing problems.

my set up is FC2 test2 with these packages installed from rawhide:

[root@markf78 home]# rpm -qa rpm libselinux policy*
policy-1.9.1-2
rpm-4.3-0.22
libselinux-1.6-5
policycoreutils-1.9-16
kernel-2.6.3-2.1.253.2.1

hope this helps...!

mark.

Version-Release number of selected component (if applicable):
rpm-4.3-0.22

How reproducible:
Always

Steps to Reproduce:
1.install any package
2.
3.
    

Actual Results:  warnings

Expected Results:  no warnings or errors

Additional info:
Comment 1 Jeff Johnson 2004-07-10 09:09:35 EDT
This is a policy, not an rpm, problem.

Note You need to log in before you can comment on or make changes to this bug.