Bug 119562 - xemacs wants older Canna
xemacs wants older Canna
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-31 08:34 EST by Kaj J. Niemi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 01:47:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2004-03-31 08:34:02 EST
Description of problem:
I think xemacs needs to be recompiled against the newer Canna although
the dynamic library versions seem to have gone backwards (newer
package version 1, older 1.2)

Version-Release number of selected component (if applicable):
xemacs-21.4.15-3

% rpm -qp --provides Canna-libs-3.7p1-6.i386.rpm
libRKC.so.1
libRKC16.so.1
libcanna.so.1
libcanna16.so.1
Canna-libs = 3.7p1-6


Steps to Reproduce:
1. rpm -Fvh Canna*3.7p1-6*
error: Failed dependencies:
        libRKC.so.1.2 is needed by (installed) xemacs-21.4.15-3
        libcanna.so.1.2 is needed by (installed) xemacs-21.4.15-3
2.
3.

Thanks :)
Comment 1 Jens Petersen 2004-03-31 09:24:37 EST
I believe this happened when Canna was updated with xmkmf from xorg-x11.

Tagoh, is the right solution to change Canna or rebuild xemacs?
Comment 2 Akira TAGOH 2004-03-31 19:42:41 EST
Jens, Canna has no idea to solve this as long as it uses the changed
xmkmf. the core part is including the ld options like -soname is
generated by xmkmf. just having libcanna.so.1.2 doesn't help so that
-soname has a decision for the soname you know. IOW current behavior
of xmkmf looks like libtool does. and I believe changing the minor
version of the soname shouldn't affects anything. so depending on
lib*.so.n is right, and rebuilding xemacs is the right solution then.
Comment 3 Jens Petersen 2004-04-01 06:18:57 EST
Thanks, should get fixed in next build.
Comment 4 Jens Petersen 2004-04-06 11:47:54 EDT
Should be fixed in 21.4.15-4.
Comment 5 Kaj J. Niemi 2004-04-08 01:47:51 EDT
Is fixed. Thanks. :)

Note You need to log in before you can comment on or make changes to this bug.