Bug 119577 - some thinkpad t40p subsystems are found/removed on every other reboot
some thinkpad t40p subsystems are found/removed on every other reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-31 10:43 EST by Kaj J. Niemi
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-02 04:57:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output from a T40p (20.71 KB, text/plain)
2004-03-31 10:46 EST, Kaj J. Niemi
no flags Details
virgin hwconf created by kudzu (when no hwconf at all exists) (3.31 KB, text/plain)
2004-03-31 10:46 EST, Kaj J. Niemi
no flags Details
hwconf created by kudzu after 2nd reboot, diff -u to attachment 99002 is interesting. (5.46 KB, text/plain)
2004-03-31 10:47 EST, Kaj J. Niemi
no flags Details
hwconf created by kudzu after 3rd reboot with most integrated subsystems removed (3.31 KB, text/plain)
2004-03-31 10:50 EST, Kaj J. Niemi
no flags Details

  None (edit)
Description Kaj J. Niemi 2004-03-31 10:43:09 EST
Description of problem:
On a IBM Thinkpad T40p, newer kudzus seem to find part of the
subsystems on every second reboot and remove them on the next. It is
sort of annoying as kudzu pops up on every restart and wants
confirmation for adding/removal of them.

Version-Release number of selected component (if applicable):
kudzu-1.1.53-1
hwdata-0.114-1
kernel-2.6.4-1.300
kernel-2.6.4-1.298
kernel-2.6.3-2.1.253.2.1 (and older)

How reproducible:
Always

Steps to Reproduce:
1. reboot
2. wait for kudzu to start/probe/exit
3. reboot in run level 3 or 5
Comment 1 Kaj J. Niemi 2004-03-31 10:46:10 EST
Created attachment 99001 [details]
dmesg output from a T40p
Comment 2 Kaj J. Niemi 2004-03-31 10:46:42 EST
Created attachment 99002 [details]
virgin hwconf created by kudzu (when no hwconf at all exists)
Comment 3 Kaj J. Niemi 2004-03-31 10:47:24 EST
Created attachment 99003 [details]
hwconf created by kudzu after 2nd reboot, diff -u to attachment 99002 [details] is interesting.
Comment 4 Kaj J. Niemi 2004-03-31 10:50:03 EST
Created attachment 99004 [details]
hwconf created by kudzu after 3rd reboot with most integrated subsystems removed

diff -u to attachment 99003 [details] is interesting, I'm not printing it here since it
is 179 lines long.

diff -u to attachment 99002 [details] (the virgin one) is only one line:

--- hwconf.virgin	2004-03-31 18:17:12.000000000 +0300
+++ hwconf.third	2004-03-31 18:34:08.281266533 +0300
@@ -101,7 +101,7 @@
 class: NETWORK
 bus: PCI
 detached: 0
-device:
+device: 9H
 driver: e1000
 desc: "Intel Corp.|82540EM Gigabit Ethernet Controller (LOM)"
 network.hwaddr: 00:0D:60:38:25:6C
Comment 5 Kaj J. Niemi 2004-03-31 10:55:22 EST
% lspci -n
00:00.0 Class 0600: 8086:3340 (rev 03)
00:01.0 Class 0604: 8086:3341 (rev 03)
00:1d.0 Class 0c03: 8086:24c2 (rev 01)
00:1d.1 Class 0c03: 8086:24c4 (rev 01)
00:1d.2 Class 0c03: 8086:24c7 (rev 01)
00:1d.7 Class 0c03: 8086:24cd (rev 01)
00:1e.0 Class 0604: 8086:2448 (rev 81)
00:1f.0 Class 0601: 8086:24cc (rev 01)
00:1f.1 Class 0101: 8086:24ca (rev 01)
00:1f.3 Class 0c05: 8086:24c3 (rev 01)
00:1f.5 Class 0401: 8086:24c5 (rev 01)
00:1f.6 Class 0703: 8086:24c6 (rev 01)
01:00.0 Class 0300: 1002:4c66 (rev 02)
02:00.0 Class 0607: 104c:ac55 (rev 01)
02:00.1 Class 0607: 104c:ac55 (rev 01)
02:01.0 Class 0200: 8086:101e (rev 03)
02:02.0 Class 0280: 8086:1043 (rev 04)

% lspci
00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller
(rev 03)
00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller
(rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage
Controller (rev 01)
00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97
Audio Controller (rev 01)
00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf
[Radeon Mobility 9000 M9] (rev 02)
02:00.0 CardBus bridge: Texas Instruments PCI1250 PC card Cardbus
Controller (rev 01)
02:00.1 CardBus bridge: Texas Instruments PCI1250 PC card Cardbus
Controller (rev 01)
02:01.0 Ethernet controller: Intel Corp. 82540EP Gigabit Ethernet
Controller (Mobile) (rev 03)
02:02.0 Network controller: Intel Corp. PRO/Wireless LAN 2100 3B Mini
PCI Adapter (rev 04)
Comment 6 Bill Nottingham 2004-03-31 23:42:17 EST
Wacky. This has happened on every test2-ish and later kernel for you?
Comment 7 Kaj J. Niemi 2004-04-01 04:32:23 EST
Yup.
Comment 8 Kaj J. Niemi 2004-04-01 07:19:54 EST
Doesn't seem to happen anymore with kudzu-1.1.54-1. I'll try some more.
Comment 9 Kaj J. Niemi 2004-04-02 04:57:14 EST
Hmm. This really doesn't happen with kudzu-1.1.54 at all. Closing as
RAWHIDE.
Comment 10 Bill Nottingham 2004-04-02 12:26:23 EST
The '9H' fix is expected in 1.1.54.

The 'half the pci devices disappearing and reappearing' baffles me
utterly. Doesn't happen on my T40p.
  
Please do reopen if it comes back. :)

Note You need to log in before you can comment on or make changes to this bug.