Bug 1195838 - stap -V reports wrong two elfutils version numbers
Summary: stap -V reports wrong two elfutils version numbers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: systemtap
Version: 6.7
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: Martin Cermak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-24 17:06 UTC by Martin Cermak
Modified: 2015-07-22 06:45 UTC (History)
3 users (show)

Fixed In Version: systemtap-2.7-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 06:45:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1333 0 normal SHIPPED_LIVE systemtap bug fix and enhancement update 2015-07-20 18:00:10 UTC

Description Martin Cermak 2015-02-24 17:06:51 UTC
stap -V reports wrong version number:

=======
# stap -V
Systemtap translator/driver (version 2.7/0.161/0.158, rpm 2.7-1.el6)
=======

This causes a few tcl sourcing errors in the testsuite. Example: 

=======
Running ./systemtap.base/callee.exp ...
ERROR: tcl error sourcing ./systemtap.base/callee.exp.
ERROR: 0.161/0.158 is not a valid version number
    while executing
"error "$vers1 is not a valid version number""
    (procedure "strverscmp" line 5)
    invoked from within
"strverscmp $ELF_Version 0.153"
    (procedure "callee_probes_p" line 3)
    invoked from within
"callee_probes_p"
    invoked from within
"if {! [callee_probes_p]} { untested "$test"; return }"
    (file "./systemtap.base/callee.exp" line 6)
    invoked from within
"source ./systemtap.base/callee.exp"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 source ./systemtap.base/callee.exp"
    invoked from within
"catch "uplevel #0 source $test_file_name""
=======

Affected testcases: callee.exp, listing_mode.exp, unprivileged_myproc.exp

Comment 1 Frank Ch. Eigler 2015-02-24 20:11:23 UTC
The problem is that stap was built against a different version
of elfutils-devel (whatever was in the buildroot) than it is
being run against (a rebased elfutils).  It is not actually a
problem, except for this test case code.

During a respin of the rpm, we could buildroot-override to the
new elfutils.

Comment 3 Martin Cermak 2015-04-15 12:30:44 UTC
Verified with systemtap-2.7-2.el6. Covered by upstream testsuite.

Comment 4 errata-xmlrpc 2015-07-22 06:45:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1333.html


Note You need to log in before you can comment on or make changes to this bug.