Bug 119633 - /usr/share/automake-VERSION links are bad practice
Summary: /usr/share/automake-VERSION links are bad practice
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-31 22:40 UTC by Stig Hackvan
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 20:18:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stig Hackvan 2004-03-31 22:40:49 UTC
.src.rpms for many of the system-config-* packages have bogus and
unnecessary build-dependencies because of symlinks to automake helper
scripts. 

Please fix this.

Here's my workaround:


--- system-config-services.spec~        2004-03-31 14:43:42.000000000
-0800
+++ system-config-services.spec 2004-03-31 14:31:13.000000000 -0800
@@ -24,6 +24,8 @@
 %prep
 %setup -q
  
+ln -svf $(ls /usr/share/automake*/install-sh | tail -1 ; ls
/usr/share/automake*/missing | tail -1) .
+
 CFLAGS="$RPM_OPT_FLAGS" ./configure \
     $MYARCH_FLAGS --enable-more-warnings=no \
     --prefix=%{_prefix} --datadir=%{_datadir} \

Comment 1 Nils Philippsen 2004-08-13 20:18:15 UTC
I don't understand what you mean -- the tarball of
system-config-services specifically doesn't contain symlinked autofoo
scripts, but copies so it is self-contained. Your proposed patch
actually introduces symlinks in a very dangerous way, using what ever
is available or not, whether it works or not.

If I misunderstood you, please reopen and rephrase ;-).


Note You need to log in before you can comment on or make changes to this bug.