Bug 119639 - Ati Radeon 9600SE unsupported
Ati Radeon 9600SE unsupported
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-31 18:29 EST by Alessandro Polverini
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 17:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessandro Polverini 2004-03-31 18:29:42 EST
Description of problem:
Anaconda can't enter graphic mode.
system-config-display does not work

Version-Release number of selected component (if applicable):
The one shipped with FC2-test2

How reproducible:
Always

Steps to Reproduce:
1. Install in text mode
2. Reboot
3. Run system-config-display --reconfig
  
Actual results:
"redhat-config-xfree86 --reconfig" does nothing with this error:
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 413, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined

Expected results:
Some kind of working xfree86, possibly using both my two Flat panels
(one DVI, one normal).
Comment 1 Mike A. Harris 2004-04-01 03:29:14 EST
>Version-Release number of selected component (if applicable):
>The one shipped with FC2-test2

rpm -q xorg-x11

That makes it easier when reading this bug report to know what version
you were using, without us having to go and look up the version that
was included in FC2t2 each time.  ;o)

Comment 2 Alessandro Polverini 2004-04-01 04:01:16 EST
Yes, I know how to use rpm, the only problem is that the machine from
which I do the bug reporting, is the same, so when I installed
FC2-test2  I forgot to do the command, and now, on FC1, I can't do it
(and I don't reboot any more, cause I'm working on it).

Anyway, looking at the FC2-test2 cd, I see this file:
/mnt/cdrom/Fedora/RPMS/xorg-x11-0.0.6.6-0.0.2004_03_11.9.x86_64.rpm

Alex
Comment 3 Alessandro Polverini 2004-04-01 10:18:33 EST
As additional information, here are the relevant lines from the output
of lspci -n:

0000:01:00.0 Class 0300: 1002:4151
0000:01:00.1 Class 0380: 1002:4171
Comment 4 Neal Becker 2004-04-05 08:23:25 EDT
Same problem with my nvidia 5900xt.  Does this help? 
sbin/lspci -n 
00:00.0 Class 0600: 1106:3188 (rev 01) 
00:01.0 Class 0604: 1106:b188 
00:0b.0 Class 0200: 10ec:8169 (rev 10) 
00:0d.0 Class 0104: 105a:3373 (rev 02) 
00:0e.0 Class 0c00: 1106:3044 (rev 80) 
00:0f.0 Class 0104: 1106:3149 (rev 80) 
00:0f.1 Class 0101: 1106:0571 (rev 06) 
00:10.0 Class 0c03: 1106:3038 (rev 81) 
00:10.1 Class 0c03: 1106:3038 (rev 81) 
00:10.2 Class 0c03: 1106:3038 (rev 81) 
00:10.3 Class 0c03: 1106:3038 (rev 81) 
00:10.4 Class 0c03: 1106:3104 (rev 86) 
00:11.0 Class 0601: 1106:3227 
00:11.5 Class 0401: 1106:3059 (rev 60) 
00:18.0 Class 0600: 1022:1100 
00:18.1 Class 0600: 1022:1101 
00:18.2 Class 0600: 1022:1102 
00:18.3 Class 0600: 1022:1103 
01:00.0 Class 0300: 10de:0332 (rev a1) 
 
Comment 5 Thomas J. Baker 2004-04-06 11:20:16 EDT
I also have this problem on my Dell Inspiron 7500 laptop with an ATI
Rage Mobility card. Running redhat-config-display --reconfig does not
work with the same 'hardware_state' error. More details of my hardware
are in the following bug about X starting but not displaying anything:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118860
Comment 6 Alessandro Polverini 2004-04-28 07:52:02 EDT
In FC2 Test3 if I run  system-config-display I got the following:

* no cardMem, assuming 8192
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None
 
* no cardMem, assuming 8192
Trying with card: VESA driver (generic)
* no cardMem, assuming 8192

And when the window opens the only resolutions I can choose from are
640x480 and 800x600.

Also, if I try to enable dual head, I see no possible choices on the
"Second Video Card" option.

Actually I think the name of the option is incorrect since I have just
on video card, but with 2 video output (one DVI, the other VGA).

Alex
Comment 7 Mike A. Harris 2004-08-30 17:37:24 EDT
$ grep 4151 /home/mharris/src/redhat/hwdata/pcitable
0x1002  0x4151  "Card:ATI Radeon 9600"  "ATI|RV350 AQ [Radeon 9600]"

Fixed in rawhide hwdata package.

Note You need to log in before you can comment on or make changes to this bug.