Bug 119657 - Gnome Pilot will not sync with Sony TH55 Palm Pilot
Gnome Pilot will not sync with Sony TH55 Palm Pilot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 00:20 EST by John Mizell
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-08 09:35:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mizell 2004-04-01 00:20:27 EST
Description of problem:
Gnome Pilot does not reconize the Sony TH55 Palm Pilot device. It
is reconized in the kernel:
usb 2-2: new full speed USB device using address 4
usbserial 2-2:1.0: Handspring Visor / Palm OS converter detected
usb 2-2: Handspring Visor / Palm OS converter now attached to ttyUSB0
(or usb/tt s/0 for devfs)
usb 2-2: Handspring Visor / Palm OS converter now attached to ttyUSB1
(or usb/tt s/1 for devfs)
I have tried to link /dev/pilot to /dev/usb/ttyUSB0 and ttyUSB1 and 
also set permissions to 777 
But it does not work and I also tried pilot-xfer -l but it does not 
come back with any information.

Version-Release number of selected component (if applicable):
gnome-pilot-2.0.10-6.1
gnome-pilot-conduits-2.0.10-2.1
kernel 2.6.3-2.1.253.2.1
How reproducible:

Every time
Steps to Reproduce:
1. Launch gnome-pilot 
2.
3.
  
Actual results:
nothing

Expected results:
Gnome-pilot reconizes palm pilot and syncs

Additional info:
Comment 1 Nigel Metheringham 2004-06-03 10:04:19 EDT
If 
  pilot-xfer -p /dev/usb/ttyUSB1 -l

doesn't work then its not a problem with gnome-pilot, but somewhere
lower down the stack.
Comment 2 Giuseppe Castagna 2004-06-04 15:01:07 EDT
I can confirm this bug, it happens for me on three different FC2
installations (two Thinkpad X40, one vanilla FC2 + updates, the other
with update testing and custom kernel, and the third on a Dell P4
workstation vanilla FC2 + updates).

And hotsync with pilot-xfer -p /dev/ttyUSB0 -t works like a charm on
all machines. Also I managed to synch my TH55 and Evolution using
multisync

Please let me know if you need me to do some testing

---Beppe---
Comment 3 Giuseppe Castagna 2004-06-04 16:41:52 EDT
BTW, here you are the log messages on a custom kernel 2.6.7-rc2


Jun  4 22:04:53 myrte kernel: usb 3-2: new full speed USB device using
address 2
Jun  4 22:04:54 myrte kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Generic
Jun  4 22:04:54 myrte kernel: usbcore: registered new driver usbserial
Jun  4 22:04:54 myrte kernel: drivers/usb/serial/usb-serial.c: USB
Serial Driver core v2.0
Jun  4 22:04:54 myrte kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Handspring Visor / Palm OS
Jun  4 22:04:54 myrte kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Sony Clie 3.5
Jun  4 22:04:54 myrte kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Sony Clie 5.0
Jun  4 22:04:54 myrte kernel: visor 3-2:1.0: Sony Clie 5.0 converter
detected
Jun  4 22:04:54 myrte kernel: usb 3-2: Sony Clie 5.0 converter now
attached to ttyUSB0 (or usb/tts/0 for devfs)
Jun  4 22:04:54 myrte kernel: usb 3-2: Sony Clie 5.0 converter now
attached to ttyUSB1 (or usb/tts/1 for devfs)
Jun  4 22:04:54 myrte kernel: usbcore: registered new driver visor
Jun  4 22:04:54 myrte kernel: drivers/usb/serial/visor.c: USB
HandSpring Visor / Palm OS driver v2.1
Jun  4 22:05:01 myrte kernel: usb 3-2: control timeout on ep0in
Jun  4 22:05:02 myrte kernel: usb 3-2: USB disconnect, address 2
Jun  4 22:05:02 myrte kernel: clie_5 ttyUSB0: Sony Clie 5.0 converter
now disconnected from ttyUSB0
Jun  4 22:05:02 myrte kernel: clie_5 ttyUSB1: Sony Clie 5.0 converter
now disconnected from ttyUSB1
Jun  4 22:05:02 myrte kernel: visor 3-2:1.0: device disconnected



while pilot-xfer -l returns

[beppe@myrte /dev]# pilot-xfer -p /dev/pilot -l
 
 
   Listening to port: /dev/pilot
 
   Please press the HotSync button now... Connected
 
Reading list of databases in RAM...
mountain.jpg
boy and girl.jpg
balloons.jpg
Cmn_Temp_EU
Cmn_Conv_EU
Cmn_Sizes_EU
CLIEFiles_CLFl_appl_a68k
ClieDemo_CLie_appl_a68k
PrintKun_ClPt_appl_a68k
CLIELauncherDB_App
CLIELauncher_SubRsc
CLIELauncherDB_Ctgr
CLIELauncherDB_Shct
User Data
AddressExDB
MemoExDB
DatebookExDB
ToDoExDB
CFEtherIFDB
200405302141329HWMe
200405130103495HWMe
200405130103120HWMe
200405130103117HWMe
200405112127421HWMe
_FN_SAMPLE03
_FN_SAMPLE02
_FN_SAMPLE01
AddressDB
Bluetooth Trusted Devices
Bluetooth Device Cache
DatebookDB
MemoDB
ConnectionMgr50DB
NetworkDB
PhoneRegistryDB
ToDoDB
200405310021025Over
200405302111042Over
200405130052148Over
200405130052067Over
StickerSmall
StickerLarge
CLIEDatebookDayDB
ExifRotator_ExRt_appl_a68k
FileDB_FLDB_appl_a68k
ClieFAQHistDB
CLIEOrganizerHolidayDB2004
ImageViewerAddressLink
MMFlash_MMFP_appl_a68k
AudioPlayer_MSAp_appl_a68k
MSBackup_MSbK_appl_a68k
CLIEDatebookMonthDB
Data Import_MsCt_appl_a68k
CmAccountDB1
CmAccountDB2
CmAccountDB3
CmAccountDB4
CmAccountDB5
CmAccountDB6
CmAccountDB7
CmAccountDB8
CmAccountSet
CmMailBodyDB
CmMailCtlDB
CmControlDB1
CmControlDB2
CmControlDB3
NF3BOOKMARKDB
NF3CACHEDB
NF3COOKIEDB
NF3FILEDIALOGDB
NF3INFODB
NF3MSDB
NF3PLUGINDB
CmRuleDB1
CmRuleDB2
CmRuleCtlDB
NF3URLHISTORYDB
CmMailDB
CmGlobalDB
CmNetworkDB
CmPIEdit_NTED_appl_a68k
CLIE Mail_NTML_appl_a68k
CmTempDB
NetLibConfig_NlCf_appl_a68k
CoMa_SHSS_appl_a68k
CLIE_Org_Address_SaAd_appl_a68k
CLIECamera_SaCm_appl_a68k
CLIEContentsDummy_SaCn_appl_a68
CLIE_Org_Viewer_SaDL_appl_a68k
CLIEExportImport_SaEi_appl_a68k
HRFontSel_SaFs_appl_a68k
CLIE_Org_Applications_SaLc_appl
CLIE_Org_MemoPad_SaMm_appl_a68k
Movie Player_SaMp_appl_a68k
CLIE_Org_FreeNotes_SaNm_appl_a6
CLIE Organizer_SaOg_appl_a68k
PIM Assist_SaPa_appl_a68k
CLIE_Org_Reference_SaRf_appl_a6
SilkLoaderApp_SaSL_appl_a68k
CLIE_Org_DateBook_SaSd_appl_a68
CLIE_Org_ToDo_SaTD_appl_a68k
Voice Recorder_SaVm_appl_a68k
Sound Utility_SdUt_appl_a68k
CFEtherNppi_SiCe_nppi_a68k
MovieInfoCache_SmMa_appl_a68k
StillApplet_StAp_appl_a68k
CLIEDatebookWeekDB
PACE Data Store Reserve
BluetoothPnl_abtp_panl_a68k
Address Book_addr_appl_a68k
ClieDemo
Graffiti 2 Demo
ClieFAQ_cFaq_appl_a68k
Calculator_calc_appl_a68k
Card Info_cinf_appl_a68k
AddressCitiesDB
AddressCompaniesDB
AddressCountriesDB
Cat�gorie M�mos
TempImg_EU
ConvImg_EU
SizesImg_EU
CFEtherSettingDB
BtExgLibDB
SmsDB
Date Book_date_appl_a68k
Dial_dial_appl_a68k
Digitizer_digi_panl_a68k
Date & Time_dttm_panl_a68k
Formats_frmt_panl_a68k
Graffiti 2 Demo_gdem_appl_a68k
General_gnrl_panl_a68k
Graffiti 2 Prefs_grfp_panl_a68k
CLIEOrganizerIcon
LauncherCW_lnch_appl_a68k
psysLaunchDB
Language Picker_lpkr_appl_a68k
Decuma DB
Decuma Prefs
MyClip_PgpfPlugIn_mCPg_appl_a68
MyClip_Content_Beam_mCbm_appl_a
MyClip_Content_Copy_mCcp_appl_a
CLIE_Viewer_mClp_appl_a68k
MyClip_Content_Move_mCmv_appl_a
MyClip_Content_Remove_mCrm_appl
MyClip_Content_SendCL_mCsM_appl
MyClip_Content_Send_mCsd_appl_a
Graffiti ShortCuts
Memo Pad_memo_appl_a68k
ConnectionMgr_modm_panl_a68k
Network_netw_panl_a68k
Graffiti 2 Demo_frFR
Graffiti 2 Demo_deDE
Owner_ownr_panl_a68k
System ADPCM Sounds
Phone_phop_panl_a68k
Preferences_pref_appl_a68k
Bluetooth Prefs Backup
Unsaved Preferences
Net Prefs
Security_secr_appl_a68k
Welcome_setp_appl_a68k
ShortCuts_shct_panl_a68k
Sons syst�me MIDI
SMS_smsm_appl_a68k
Saved Preferences
AddressStatesDB
FlashPlayerSample.swf
NF3AUTHINFO
VisitLog
_AddrImg0002
_AddrImg0003
_AddrImg0001
AddressTitlesDB
To Do List_todo_appl_a68k
 
List complete. 176 files found.
Time elapsed: 0:00:02


Comment 4 Giuseppe Castagna 2004-06-05 21:09:41 EDT
I have also tried to recompile gpilotd (2.0.10) after having added
vendor and devices for the TH55

	"Vendor=054c ProdID=0144", /* Sony Clie UX50 - TH55 */

but with no result.

The same problems happens also when I try to sync with networks (the
TH55 has biult-in wifi connectivity)

pilot-xfer -p net:10.0.0.200 -l

works nicely, but netword sync with gpilotd does not.
Comment 5 John Mizell 2004-06-05 21:12:04 EDT
pilot-xfer -p /dev/usb/ttyUSB1 -l works for me with kernel 2.6.6-1.376
but I still cannot use gpilot.

John Mizell
Comment 6 Timothy Dixon 2004-06-21 20:38:36 EDT
I can also confirm this bug.  pilot-xfer, multisync, jpilot all work,
but gpilot will not.  Also, pilot-xfer will not work when gpilotd is
running. Running kernel 2.6.6-1.435
Comment 7 François Jan 2004-06-23 16:28:15 EDT
Hi, I found this on the pilot-link wiki site
(http://wiki.pilot-link.org/title/Palm+Device+Matrix):

To make the newer Clié devices work with gnome-pilot, they must be
added to a hardcoded list of devices in gpilotd.c (USB ids in
vendor_product_ids and an additional product_net = TRUE)

On this same page, you can find your device and his numbers.

Well, for me, after modifying the file and recompiling, it works (TH55)...
Comment 8 Giuseppe Castagna 2004-06-24 05:33:17 EDT
Uh! It does not work for me. I took gnome-pilot-2.0.10-6.1.src.rpm in
the Fedora rawhide (I use kernel 2.6.6-1.435), modified the lines in
gpilotd.c namely added 

        "Vendor=054c ProdID=0144", /* Sony Clie TH55 */

and an extra  product_net = TRUE, compiled, installed, and ... nothing
happens. gpilotd is still quiet when I press hotsynch on my craddle
(while pilot-xfer happily synchronizes).

I also tried to checkout gnome-pilot from the CVS and to compile it
but autogen creates a buggy configure file that ends with the
following error

checking for gob2... no
./configure: line 21460: syntax error near unexpected token `2.0.3'
./configure: line 21460: `      GOB2_CHECK(2.0.3)'


What am I doing wrong? Could you pack a rpm binary and post it here
please? Thanks in advance

Beppe

Comment 9 Dave Malcolm 2004-09-21 20:25:39 EDT
If you download gnome-pilot-2.0.11 or later (gnome-pilot-2.0.12 is in
Rawhide), you'll find that the device information is now in an
separate data file: /usr/share/gnome-pilot/devices.xml

I don't have the relevant hardware to test this, but if you edit this
file as root it should be possible to add an extra XML element giving
the TH55 data (follow the pattern used by the rest of this file).

If it works, please let me know, so we can get the change into the
upstream packages.
Comment 10 Giuseppe Castagna 2004-09-24 06:53:22 EDT
<!-- Sony Clie UX50 -->
 <device vendor_id="054c" product_id="0144" />


This works also for TH55 (at least now it starts synchronizing, but
then it crashes (but I think this is related to my data so this is a
defferent bug report). So to close the bug (for me) you can just
modify the XML comment :-)

<!-- Sony Clie UX50 and TH55-->

Thanks

---Beppe---
Comment 11 Dave Malcolm 2004-09-24 15:02:53 EDT
What version of gnome-pilot are you now running?  Can you attach a
stack trace of the crash to this bug?  see:
http://fedora.linux.duke.edu/wiki/StackTraces
Comment 12 Giuseppe Castagna 2004-09-24 15:14:24 EDT
gnome-pilot-2.0.12 from Fedora rawhide. The crash was due to a "very
old" calendar entry in my evolution (2003) with French accents. I have
just erased all my calendar (the first entry was in 2002 and it was
very corrupted by several experiments with multisync, palm bluetooth,
all you can immagine) and started it from scratch (I am not a
fetishist) and it works like a charm, now. But if you want I kept a
copy of my old Calendar: I can either sent to you or make an experiment

B.
Comment 13 John Mizell 2004-09-25 20:49:00 EDT
I can sync as root but only when I change the permissions on the
/dev/ttyUSB2 or the other device /dev/ttyUSB0 when they are created
can I sync as a normal user. The palm pilot when syncing will talk to
hal and then hal creates one of the two devices but it does not seem
to be consistant with device naming.
Comment 14 Frank Lin 2004-09-28 10:14:48 EDT
I am running stock FC2, with upgraded gnome-pilot to
gnome-pilot-2.0.12-3, and gnome-pilot-conduits-2.0.10-2.1.  By using
pilot-xfer, everything works find.  But using gnome's PalmOS devices
setup, with added lines to the XML file (in Comment #10).  And I still
can't make it to work...

I don't know what else to try, what I am doing diff then you guys...
Comment 15 John Mizell 2004-09-28 10:21:53 EDT
I was using Fedora Core 3 test 2 with my last statement.
Comment 16 Frank Lin 2004-09-28 11:29:21 EDT
I am still using the stock 2.6.8-1.521 kernel, but I don't think this
matter, since pilot-xfer works fine, and you guys have tried it with
gnome-pilot-2.0.12... is this the right version?  Or other things in
FC3 with gnome2.8?
Comment 17 Giuseppe Castagna 2004-09-28 17:29:22 EDT
Here you are what I use:

[beppe@myrte CDUCE]$ rpm -qa | grep gnome-pilot
gnome-pilot-conduits-2.0.12-2
gnome-pilot-2.0.12-2
gnome-pilot-devel-2.0.12-2

downloaded from Fedora rawhide.

The kernel is 2.6.8-1.521

It works nicely. Silly question but, are you sure that you started
gpilotd?

---Beppe---
Comment 18 Frank Lin 2004-09-29 10:41:13 EDT
I finally got it working! :)  Thanks for all the help... It turn out
to be a permission problem.

I have FC2 both at work and at home.  At work, I only had to change
the permission to 0666 for /dev/ttyUSB0 for the sync to work.  But for
my home, I think I got devfs, devpts or hot-plug of some sort running
where it creates /dev/ttyUSB0 automatic for me, and on disconnect it
removes the devices.  

I could always chmod on connect of my clie, but anyone knows how to
mount those devices with 0666 permission?

+frank http://www.weink.net


Note You need to log in before you can comment on or make changes to this bug.