Bug 119730 - orinoco_cs wireless lan card not working (works in FC1)
orinoco_cs wireless lan card not working (works in FC1)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 15:51 EST by Santiago Erquicia
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 10:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Santiago Erquicia 2004-04-01 15:51:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
The wireless card that was working under FC1 is not working in this
version.

It looks like it is recognized because I installed test2 from scratch
and it appears in the configuration screen.

If I try to activate it, this is the error message that shows up:
orinoco_cs device eth1 does not seem to be present, delaying
initialization.

I went to hardware browser and only shows the other ethernet card, not
the wireless one.

I don't know what can I do to give you better information about the
card.  It came with the computer (Toshiba Satellite) so I don't know
exactly the model or brand.

Version-Release number of selected component (if applicable):
system-config-network-1.3.16-1

How reproducible:
Always

Steps to Reproduce:
1.Open the configuration program
2.Press Activate
3.
    

Actual Results:  The card doesn't work

Expected Results:  The card is loaded and get's an IP

Additional info:
Is this wireless driver working with the kernel kernel-2.6.4-1.298
?
Comment 1 Harald Hoyer 2004-04-02 02:24:46 EST
it should work.
what does
# service pcmcia start
# iwconfig eth1
# lsmod
output, after you insert the card?
is the pcmcia service activated?
Comment 2 Santiago Erquicia 2004-04-02 02:39:08 EST
I went to the service manager and pcmcia is ticked, but it is not
working.  I tried to run it and nothing happens.

Under the service configuration GUI this is the message: cardmgr is
stopped

When trying to run the commands in the console this is what happens:

[root@localhost santiago]# /sbin/service pcmcia start
Starting PCMCIA services: cardmgr[4957]: no sockets found!
done.
[root@localhost santiago]# /sbin/iwconfig eth1
eth1      No such device

I think the last one is because the pcmcia is not working.

What else can I do to help you out?
Comment 3 Harald Hoyer 2004-04-02 03:02:53 EST
I am reassing this bug to pcmcia.
Comment 4 Arjan van de Ven 2004-04-02 03:05:32 EST
that's not too helpful since pcmcia-cs doesn't do hardware; that's the
kernel ...
Comment 5 Don Hardaway 2004-04-02 12:43:20 EST
I need help too--can't get my netgear wg511 54mb card to work.
Comment 6 Don Hardaway 2004-04-02 14:29:59 EST
when i launch network--it sees my card as generic prism but no lights
come on the card and it does not work.
Comment 7 Don Hardaway 2004-04-02 15:46:22 EST
here is what it says when i try to activate my network card:

determining IP information for eth1...SIOCSIFFLAGS: No such file or
directory
SIOCSIFFLAGS: No such file or directory
Comment 8 Santiago Erquicia 2004-04-02 18:50:31 EST
I updated to the kernel kernel-2.6.4-1.303 and it still hapening.
Comment 9 Don Hardaway 2004-04-03 09:41:05 EST
I just updated to kernel-2.6.4-1.305 and still can not get the 54mb
wg511 card with prism chip to light up and work.
Comment 10 Arjan van de Ven 2004-04-03 09:45:32 EST
Don: I think you have an entirely different category card than
Santiago has; would you mind using a separate bug for that to
deconfuse this bug ?
Comment 11 Larry 2004-04-07 19:32:31 EDT
I have the same problem. I am running a Proxim Orinoco Classic Gold 
802.11B Wireless PC Card part # 8410-WD
Comment 12 Vladimir Petrov 2004-04-13 07:31:29 EDT
I installed today FC2 Test 2 via my wireless card (FTP install) ZyAIR
100 on Compaq Armada m300 (PIII 600) and everything went fine until FC
was installed. Then ZYAIR was not recognised (neither pcmcia slot). I
got the same messages as Santiago Erquicia described in his posts. It
seems that all drivers are loaded (part of lsmod out):
orinoco_cs    7432  0
ds           10244  1 orinoco_cs
pcmcia_core  52452  2 orinoco_cs,ds
orinoco      44684  1 orinoco_cs
hermes       6656   2 orinoco_cs,orinoco
Comment 13 Vladimir Petrov 2004-04-14 02:21:07 EDT
It seems that problem is with pcmcia driver. I tried 3com
Megahertz(3c574BT) card and neither this one was initialized...
Comment 14 Antti Markus 2004-04-22 08:46:43 EDT
http://fedoranews.org/colin/fnu/issue7.shtml seems to describe the
problem and offers a workaround (/sbin/modprobe yenta_socket,
/etc/init.d/pcmcia start). 
Comment 15 Antti Markus 2004-04-24 15:58:46 EDT
See bug 105591 for solution (PCMCIA should be started before network) 
Comment 16 Antti Markus 2004-05-03 02:01:24 EDT
This problem seems to be solved in FC2 test3.

Note You need to log in before you can comment on or make changes to this bug.