Bug 1197503 - rebuild needed after qt5 update
Summary: rebuild needed after qt5 update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1201510 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-01 20:05 UTC by Nerijus Baliūnas
Modified: 2015-04-02 15:34 UTC (History)
10 users (show)

Fixed In Version: calibre-2.22.0-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-02 15:34:46 UTC


Attachments (Terms of Use)

Description Nerijus Baliūnas 2015-03-01 20:05:20 UTC
ebook-convert book.epub book.mobi works OK with qt5-qtbase-5.4.0-2.fc21, but after update to 5.4.1-1.fc21 from updates-testing, I get:
...
Applying case-transforming CSS...
python2: symbol lookup error: /usr/lib/calibre/calibre/plugins/libheadless.so: undefined symbol: _ZN20QPlatformIntegration11screenAddedEP15QPlatformScreen

Comment 1 Kevin Fenzi 2015-03-01 20:31:48 UTC
I can do so, but adding Rex here as I don't know if this should be attached to an existing f21 update or it's own update. 

Ie, did this happen to you in f21 with stable updates?

Comment 2 Nerijus Baliūnas 2015-03-01 22:05:14 UTC
F21 with updates-testing. With updates (w/o testing) it works OK.

Comment 3 Rex Dieter 2015-03-02 03:16:13 UTC
I'll try to do some testing tomorrow, and batch it along with qt-5.4.1 if necessary.

Comment 4 Andras Simon 2015-03-28 19:47:10 UTC
I experience the same problem with qt5-qtbase.x86_64 0:5.4.1-3 and calibre-2.15.0-2.

Comment 5 Stefan Becker 2015-03-29 08:04:20 UTC
*** Bug 1201510 has been marked as a duplicate of this bug. ***

Comment 6 Stefan Becker 2015-03-29 08:21:55 UTC
I just updated to F21 stable updates and now I run into the same problem when using "ebook-convert":

python2: symbol lookup error: /usr/lib64/calibre/calibre/plugins/libheadless.so: undefined symbol: _ZN20QPlatformIntegration11screenAddedEP15QPlatformScreen

$ c++filt _ZN20QPlatformIntegration11screenAddedEP15QPlatformScreen
QPlatformIntegration::screenAdded(QPlatformScreen*)

According to the QT source code, this interface no longer exists:

 https://qt.gitorious.org/qt/qtbase/blame/HEAD:src/gui/kernel/qplatformintegration.h
 https://qt.gitorious.org/qt/qtbase/commit/52f5e50f11a3ba82e32dc2efc656e4021a3fa4f5

It is now

  void screenAdded(QPlatformScreen *screen, bool isPrimary = false);

$ readelf --all --wide /usr/lib64/libQt5Gui.so.5.4.1 | fgrep screenAdded
...
  7708: 00000000000d84a0   215 FUNC    GLOBAL DEFAULT   12 _ZN20QPlatformIntegration11screenAddedEP15QPlatformScreenb

If I understand C++ correctly, this should be fixed by a rebuilt.

Comment 7 Stefan Becker 2015-03-29 08:53:36 UTC
I triggered a scratch build on Koji

  http://koji.fedoraproject.org/koji/taskinfo?taskID=9358894

After installing the rebuilt RPM

  https://kojipkgs.fedoraproject.org//work/tasks/8896/9358896/calibre-debuginfo-2.15.0-2.fc21.x86_64.rpm

ebook-convert works correctly again.

Unfortunately I don't have the rights to push an official rebuild.

Comment 8 Fedora Update System 2015-03-30 14:09:12 UTC
calibre-2.22.0-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/calibre-2.22.0-1.fc21

Comment 9 Fedora Update System 2015-03-31 21:49:05 UTC
Package calibre-2.22.0-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing calibre-2.22.0-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5132/calibre-2.22.0-1.fc21
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-04-02 15:34:46 UTC
calibre-2.22.0-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.