Bug 119762 - automount and mounting through "computer" is messed up
automount and mounting through "computer" is messed up
Status: CLOSED DUPLICATE of bug 119763
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 19:55 EST by Scott Sloan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errors on Kernel load that could've contributed (1.21 KB, text/plain)
2004-04-01 20:44 EST, Scott Sloan
no flags Details

  None (edit)
Description Scott Sloan 2004-04-01 19:55:08 EST
Description of problem:

automount doesn't work in latest version of nautilus even if options
are specified through control panel cd/dvd properties

also, I have a scandisk compact flash card reader as /dev/sha1 when
(test1) I inserted media and went to "computer" on the user desktop,
right clicked and clicked mount, media would be mounted.

in test2, it yells at me saying only root can mount
Comment 1 Scott Sloan 2004-04-01 20:34:55 EST
logs show this

Apr  1 18:54:40 localhost kernel: audit(1080867280.631:0): avc: 
denied  { getattr } for  pid=3497 exe=/usr/libexec/gnome-vfs-daemon
path=/mnt/flash dev=sda1 ino=1 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:dosfs_t tclass=dir
Apr  1 18:54:40 localhost kernel: audit(1080867280.634:0): avc: 
denied  { getattr } for  pid=3212 exe=/usr/bin/nautilus
path=/mnt/flash dev=sda1 ino=1 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:dosfs_t tclass=dir
Comment 2 Scott Sloan 2004-04-01 20:44:49 EST
Created attachment 99057 [details]
Errors on Kernel load that could've contributed
Comment 3 Scott Sloan 2004-04-02 11:45:37 EST
This happens because of what is happening in:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119763

With selinux disabled: both automount and mounting other disk works
correctly. 

But we need it to work with selinux enabled... well I think we do.
Comment 4 Bill Nottingham 2004-04-05 18:00:34 EDT

*** This bug has been marked as a duplicate of 119763 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:02:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.