Bug 119763 - mount points disappear for user
mount points disappear for user
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
: 119762 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 20:02 EST by Scott Sloan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-02 23:17:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Sloan 2004-04-01 20:02:04 EST
Description of problem

harddrive1 = /dev/hda  (has swap / and /boot partitions)
harddrive2 = /dev/hdb  (has /stor  partition for mass storage  owner
set to 501)

user 501 doesn't have access to the drive, nor does it appear under
nautilus for the user even though he is the user. first saw this bug
and reported it as 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119517

which has a screenshot of it occuring under mozilla. 

Didn't know where to post it, thinking it is selinux related
Comment 1 Scott Sloan 2004-04-01 20:36:32 EST
logs show this

Apr  1 18:39:13 localhost kernel: audit(1080866353.616:0): avc: 
denied  { getattr } for  pid=3213 exe=/usr/bin/nautilus path=/stor
dev=hdb1 ino=2 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=dir
Apr  1 18:39:13 localhost kernel: audit(1080866353.754:0): avc: 
denied  { getattr } for  pid=3176 exe=/usr/bin/nautilus path=/stor
dev=hdb1 ino=2 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=dir
Apr  1 18:39:13 localhost kernel: audit(1080866353.912:0): avc: 
denied  { getattr } for  pid=3176 exe=/usr/bin/nautilus path=/stor
dev=hdb1 ino=2 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=dir
Comment 2 Scott Sloan 2004-04-02 11:38:28 EST
With Setting: 

/etc/sysconfig/selinux

selinux=disabled

I can properly access the directories, so this is a direct symptom of
selinux. 

To me it seems that selinux is ignoring the file owner and properties
and over-riding them by whatever is listed in a policy somewhere. I
don't think this should be. Shouldn't file rights over ride policy?
Comment 3 Daniel Walsh 2004-04-02 23:17:46 EST
What kind of file systems is mounted on /stor.  

SELinux overrides DAC or file owner/properties.  The problem here is
this is a mislabled file system.  If you want a user to be able to
access the file system, you could mount it with 
context=system_u:object_r:user_home_t
Comment 4 Bill Nottingham 2004-04-05 18:00:35 EDT
*** Bug 119762 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.