Bug 119777 - (AGP)agpgart: Unsupported Intel chipset (device id: 1a30) [i845]
Summary: (AGP)agpgart: Unsupported Intel chipset (device id: 1a30) [i845]
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-02 03:11 UTC by John Reiser
Modified: 2015-01-04 22:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-09 00:18:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (-v, -vv, -n) (11.13 KB, text/plain)
2004-04-02 03:12 UTC, John Reiser
no flags Details
/etc/sysconfig/hwconf (5.73 KB, text/plain)
2004-04-02 03:13 UTC, John Reiser
no flags Details

Description John Reiser 2004-04-02 03:11:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
In FC2T2, dmesg shows
-----
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Unsupported Intel chipset (device id: 1a30)
agpgart: Detected an Intel i845 Chipset.
agpgart: Maximum main memory to use for agp memory: 941M
agpgart: AGP aperture is 64M @ 0xf8000000
-----
which is bad because i845 should be fully understood.

There are no agpgart complaints from FC2T1 on the same hardware (or
from FC1 or RedHat 9; but for these last two kernels, dmesg does not
have any agpgart messages at all.)


Version-Release number of selected component (if applicable):
kernel-2.6.4-1.300

How reproducible:
Always

Steps to Reproduce:
1. Boot ASUS P4B266 with i845 chipset.
2.
3.
    

Actual Results:  As in Descrption.

Expected Results:  No complaints for i845 chipset.

Additional info:

Comment 1 John Reiser 2004-04-02 03:12:47 UTC
Created attachment 99060 [details]
lspci output (-v, -vv, -n)

Comment 2 John Reiser 2004-04-02 03:13:29 UTC
Created attachment 99061 [details]
/etc/sysconfig/hwconf

Comment 3 Dave Jones 2004-04-02 09:37:21 UTC
ah, the 'unknown' is coming from the ia32e driver running in 32bit mode.
I'll fix that up.

Comment 4 Dave Jones 2004-05-07 21:45:20 UTC
should be fixed now ?


Comment 5 John Reiser 2004-05-07 22:20:24 UTC
Yes, fixed in kernel-2.6.5-1.349 (probably even in 2.6.5-1.327).


Note You need to log in before you can comment on or make changes to this bug.