Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1197788 - Refresh host capabilities missing from Python-SDK
Summary: Refresh host capabilities missing from Python-SDK
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Juan Hernández
QA Contact: Karolína Hajná
URL:
Whiteboard:
Depends On:
Blocks: 1197656
TreeView+ depends on / blocked
 
Reported: 2015-03-02 15:43 UTC by Juan Hernández
Modified: 2016-04-20 01:28 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1197656
Environment:
Last Closed: 2016-04-20 01:28:43 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 38287 0 master MERGED restapi: Add action to refresh host capabilities Never

Description Juan Hernández 2015-03-02 15:43:48 UTC
+++ This bug was initially created as a clone of Bug #1197656 +++

Description of problem:
There is no way to Refresh host capabilities via Python-SDK
The only way to Refresh host capabilities is via url ovirt-engine/api/hosts/<HOST_ID>;force

Version-Release number of selected component (if applicable):
rhevm-sdk-python-3.5.0.8-2.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
API = API(url=URL, username=USERNAME, password=PASSWORD, insecure=True)
HOST = API.hosts.get(HOSTS)


Actual results:
No Refresh host capabilities under HOST object

Expected results:
Should be Refresh host capabilities under HOST object

--- Additional comment from Juan Hernández on 2015-03-02 05:56:27 EST ---

This happens because currently the generator of the Python SDK ignores any parameter that is passed to the entity resource, it only takes into account the parameters passed to the collection resource.

Comment 1 Juan Hernández 2015-03-02 15:47:28 UTC
The right way to solve this issue is to explicitly represent the "refresh host capabilities" action, instead of using the somewhat obscure (and unsupported by the Python SDK) "force" matrix parameter of the GET method. Once this is implemented in the engine the Python SDK will need to be regenerated.

Comment 2 Karolína Hajná 2015-04-29 08:19:18 UTC
Verified on rhevm-sdk-python.noarch 0:3.6.0.0-0.2.20150406git5290ed3.el7


Note You need to log in before you can comment on or make changes to this bug.