Bug 119823 - exiting man pages gives nroff Broken Pipe error
Summary: exiting man pages gives nroff Broken Pipe error
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-02 14:11 UTC by James Walton
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 19:43:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Walton 2004-04-02 14:11:34 UTC
Description of problem:
Exiting man pages throws the following error message
/usr/bin/nroff: line 69:  3304 Done                    /usr/bin/iconv
-f ${charset_in} -t utf-8 ${TMPFILE}
      3305                       | /usr/bin/groff -mtty-char -Tutf8
$opts 2>/dev/null
      3306 Broken pipe             | /usr/bin/iconv -f utf-8 -t
${charset_out}//translit


Version-Release number of selected component (if applicable):
groff-1.18.1-34

How reproducible: Every Time


Steps to Reproduce:
1. Read man page (i.e. man ps)
2. Exit man page
3.
  
Actual results: Error message as seen above

Expected results: No error


Additional info:

Comment 1 Eido Inoue 2004-04-19 19:43:38 UTC
by "quitting", I guess you mean pressing "q" during the pager. In
which case, I couldn't reproduce your bug using the latest man with
groff-1.18.1-30.

However, the pipe is generated by man, not groff.



Note You need to log in before you can comment on or make changes to this bug.