Bug 119896 - Useability - there is no way to install an RPM
Summary: Useability - there is no way to install an RPM
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-02 22:38 UTC by Joel Grimes
Modified: 2014-03-17 02:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 23:14:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joel Grimes 2004-04-02 22:38:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
RPM files are not associated with any application by default.  Thus,
there is no (graphical) way to install an RPM that isn't included in
the install cd's.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download an RPM you want to install
2. Double-click on it


    

Actual Results:  Dialog box: There is no application associated with
this file type.

Expected Results:  Some kind of graphical installer or an explanation
of how to install an rpm 

Additional info:

In addition, add/remove applications doesn't allow you to select
anything that isn't on the install cds.  This means that there is no
way to install an rpm.

If a user downloads an rpm, they are left to guess that they have to
bring up a terminal and type in "rpm -i...."

rpm files should be associated with an application.  Didn't there used
to be a program called gnorpm?

Comment 1 Jeff Johnson 2004-04-03 21:47:29 UTC
The Real difficulty is that the IANA mime-type associated with
*.rpm is for audio, not binary, bits.

Off to distribution in the vain hope that something might be done ...

Comment 2 Bill Nottingham 2004-04-06 04:53:00 UTC
The problem is that you can't really associate it with
redhat-config-packages, because:

a) randomly installing software that's downloaded seems a little bad
b) it doesn't handle source RPMs



Comment 3 Bill Nottingham 2005-03-02 21:42:43 UTC
Paul, planning on handling this sort of thing in PUP?

Comment 4 Paul Nasrat 2005-03-02 22:16:16 UTC
Probably not in it's first incarnation, but it seems like a sensible goal to
handle within the local file browser.  I'll keep this one until pup goes in then
transfer it as an RFE there.

Comment 5 Rahul Sundaram 2005-09-07 21:56:17 UTC
Transferring to Pup in development tree

Comment 6 Jeremy Katz 2006-01-24 23:14:11 UTC
This should be fixed with pirut-0.9.5 and later

Comment 7 David Lawrence 2006-06-28 01:31:27 UTC
Moving component to pirut. Sorry for the spam.


Note You need to log in before you can comment on or make changes to this bug.