Bug 119910 - Link Launcher added to gnome panel does not work
Link Launcher added to gnome panel does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 20:51 EST by Gerry Tool
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 12:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2004-04-02 20:51:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Using Add to Panel > Launcher to add a Link creates an icon, but when
the icon is clicked, instead of a browser opening with the link
displayed, I get an error box that says 

Cannot show http://www.theclearing.org/

Details: There was an error launching the default action command
associated with this location.

Version-Release number of selected component (if applicable):
gnome-panel-2.5.92-1

How reproducible:
Always

Steps to Reproduce:
1.Right click gnome panel
2.Select Add Launcher
3.Enter URL for link and select Type: Link
4.Click on icon.


Actual Results:  Error occurs

Expected Results:  Page associated with link should open in default
browser

Additional info:
Comment 1 Mark McLoughlin 2004-04-08 10:55:16 EDT
Seems to work fine with latest Raw Hide. I think its probably been
fixed. Thanks for reporting it though :) If you still see it next time
you update, please re-open
Comment 2 Gerry Tool 2004-04-08 13:51:49 EDT
I just updated all my packages from development (4/8/04 at 13:00 EDT)
and this still doesn't work.

Clicking on the panel icon I created to a valid URL gives a dialog:

Cannot show http://www.theclearing.org/index.php

Details: There was an error launching the default action command
associated with this location.

Gerry
Comment 3 Mark McLoughlin 2004-04-14 10:03:47 EDT
Hmm, was this a clean install of FC2 or did you update from FC1?
Comment 4 Gerry Tool 2004-04-14 20:11:22 EDT
In answer to an e-mail from bugzilla@redhat.com, this was a fresh
install of FC2, not an upgrade of FC1.
Comment 5 Mark McLoughlin 2004-08-11 04:30:20 EDT
What does the .desktop file for the launcher contain? 

(You'll find the .desktop files for the launchers on the panel in
~/.gnome2/panel2.d/default/launchers/)
Comment 6 Gerry Tool 2004-08-11 10:11:14 EDT
I just tried to create a link on the panel and this now works for me
in a completely up2date FC2.

The file contains:

[Desktop Entry]
Version=1.0
Encoding=UTF-8
Type=Link
URL=http://www.theclearing.org/
TryExec=
X-GNOME-DocPath=
Terminal=false
Icon=neat-control.xpm
Name[en_US]=Clearing
GenericName[en_US]=
Comment[en_US]=

It took me a while to figure out which file to look at since Nautilus
just shows the icon and its name.

I expect this bug can be closed.
Comment 7 Mark McLoughlin 2004-08-11 12:06:49 EDT
Thanks much

Note You need to log in before you can comment on or make changes to this bug.