Bug 119913 - Existing grub boot loader is deleted by installer when "no boot loader" option is chosen
Existing grub boot loader is deleted by installer when "no boot loader" optio...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 21:31 EST by Erwin J. Prinz
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 18:11:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erwin J. Prinz 2004-04-02 21:31:25 EST
Description of problem:
I have an existing Fedora Core 1 (FC1) installation on my hard drive.
When installing Fedora Core 2 Test 2 (FC2T2) from ftp (since hard
drive install did not work- already reported), I checked the "no boot
loader" option expecting that the existing boot loader would not be
affected. After successful installation and removal of the boot.iso
CD, the reboot stopped with a grub> prompt. I assume that the boot
loader on /dev/hda has been replaced with a new one pointing to /boot,
but since I checked "no boot loader" the /boot/grub/menu.lst file was
not created. I verified that by booting in "rescue mode" with the
boot.iso CD, selecting the FC2T2 install, doing chroot /mnt/sysimage,
and inspecting /boot/grub. There was no "menu.lst" file.
I then booted into rescue mode again and selected the FC1
installation, did a grub-install, and rebooted. However, I did not
know the correct line for /boot/grub/menu.lst applicable for FC2T2.
Therefore, I re-installed Fedora Core 2 Test 2 from ftp again and this
time selected to install the boot loader. This time the
/boot/grub/menu.lst file was generated and I could boot and log in.
The lines needed to boot FC2T2 are different from FC1 and not obvious
to the uninitiated.
The resolution for this bug may be to not install a boot loader (i.e.
not to overwrite grub) if the "no boot loader" option is checked. It
is also safer to write a /boot/grub/menu.lst file somewhere so the
correct 4 lines can be inferred and added to an existing grub bootloader:
title Fedora Core (2.6.3-2.1.253.2.1)
        root (hd1,0)
        kernel /vmlinuz-2.6.3-2.1.253.2.1 ro root=LABEL=/12 rhgb quiet
        initrd /initrd-2.6.3-2.1.253.2.1.img


Version-Release number of selected component (if applicable):
9.2-2

How reproducible:
Didn't try

Steps to Reproduce:
1. Install FC2T2 on a hard drive which (on other existing partitions)
contains FC1. Only select and label partitions which are not used by FC1.
2. Check "no boot loader" option during install.
3. Reboot after install.

Actual Results:  After reboot, booting stops with grub> prompt.

Expected Results:  grub should read /boot/grub/menu.lst, display the
menu, and boot.

Additional info:

Let me know if I should try to reproduce the bug (by re-installing
FC2T2;-).
Comment 1 Erwin J. Prinz 2004-04-03 16:16:29 EST
I repeated the entire procedure on a different computer (Dell D300).
This time the boot loader did NOT get deleted. The only difference in
the setup is that that machine has RH9 installed instead of FC1.
Comment 2 Erwin J. Prinz 2004-04-03 16:18:42 EST
I repeated the entire procedure on a different computer (Dell D300,
Pentium 2,compared to the previous Dell XPS T600, Pentium 3). This
time the boot loader did NOT get deleted. The only difference in the
setup is that that machine has RH9 installed instead of FC1.
Comment 3 Jeremy Katz 2004-04-05 18:11:15 EDT
"No boot loader" should only be used when you're using a 3rd party
boot loader such as boot magic.  We still upgrade the grub package
which moves some files around and probably led to the problems you had.

Note You need to log in before you can comment on or make changes to this bug.