Bug 119930 - Folders that are link don't show the emblem
Folders that are link don't show the emblem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-03 12:50 EST by Santiago Erquicia
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 09:40:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Santiago Erquicia 2004-04-03 12:50:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
When you set a link to a folder that has some emblem in your desktop,
the link doesn't show it.  If you right click on the link, it shows
that the emblem is set.

Version-Release number of selected component (if applicable):
nautilus-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1.Set an emblem in a folder
2.Make a link to that folder in your desktop
3.
    

Actual Results:  The link folder doesn't show the emblem

Expected Results:  It should show the emblem of the folder

Additional info:

I don't know if this is because nautilus cannot show more than one
emblem and the link is considered one.
Comment 1 Santiago Erquicia 2004-08-11 08:20:47 EDT
It is working fine now using the latest version in FC2.  Should this
bug be closed?
Comment 2 Mike Ginou 2004-09-14 11:26:27 EDT
Is this a duplicate of 110606?

And I do not believe that this should be closed. On my FC2 (fully
updated, no custom built packages) machine, this behaviour is still
exhibited:

Symlinks to folders only display the Symlink Emblem (Green bended
arrow). Other themes correctly display multiple emblems, however.

As alluded to above, the problem does not appear to be related to
symlinks in particular, but rather all folders in general. It would
appear that Bluecurve restricts folders to a single emblem (attempts
to add multiple emblems will fail to display any emblems except for
the first one selected).

In the particular case of symlinks to folders, the default icon will
always be displayed (you can't toggle it off), thus the single spot
for emblem display is always occupied.

Other themes seem to correctly handle this (in particular, I can
verify that Mandrake's Galaxy works fine, but most/all others that are
included with FC2 will correctly show multiple emblems).

Relevant Package:
redhat-artwork-0.96.1
nautilus-2.6.0-4
Comment 3 Alexander Larsson 2004-09-15 03:31:46 EDT
Yes. This seems to still happen in fc3test2.
Comment 4 Mike Ginou 2004-09-16 09:17:36 EDT
There is a related bug in Gnome bugzilla that is worth keeping an eye on:
http://bugzilla.gnome.org/show_bug.cgi?id=147352
Comment 5 Mike Ginou 2004-09-27 13:15:11 EDT
When a folder is opened, the multiple emblems will appear!

Additionally, the original emblem (i.e. the only one that shows up
when the folder is unopened) is moved to a new location (upper right
instead of lower left).

Steps to Reproduce:
(Using Spatial Nautilus)
1. Open a folder (refered to as X) with subfolders
2. Choose a subfolder (refered to as Y)
3. Add an emblem (refered to as e1) to Y (any emblem)
4. Notice that the emblem, e1, is displayed.
5. Add a second emblem (refered to as e2) to Y.
6. Notice that e2 is NOT displayed.
7. Double click Y to open it (in a new window)
8. Observe that the icon for Y in folder X now displays emblems e1 AND
e2 (and that the position of e1 has shifted)
Comment 6 Alexander Larsson 2004-10-05 09:40:07 EDT
This should be fixed in the latest redhat-artwork in rawhide.

Note You need to log in before you can comment on or make changes to this bug.