Bug 119973 - X ignores XFree86 nocaps setting in /etc/X11/XF86Config
X ignores XFree86 nocaps setting in /etc/X11/XF86Config
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-04 09:12 EDT by Nakai
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 15:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nakai 2004-04-04 09:12:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Addint nocaps setting

Option  "XkbOptions"    "ctrl:nocaps"

into /etc/X11/XF86Config
doesn't make sense in FC2T2.


Version-Release number of selected component (if applicable):
xorg-x11-0.0.6.6-0.0.2004_03_11.9

How reproducible:
Always

Steps to Reproduce:
1. Add nocaps line to /etc/X11/XF86Config
2. Restart X
3. Press Caps Lock key
4. Still Caps Lock
    

Actual Results:  Caps Lock

Expected Results:  Ctrl

Additional info:

It worked in FC2T1.
Comment 1 Len Trigg 2004-04-04 21:58:35 EDT
FYI, same also happens for 

Option  "XkbOptions"    "ctrl:swapcaps"

Comment 2 Len Trigg 2004-04-04 23:20:09 EDT
The nocaps setting works fine with selinux disabled (I haven't tried
swapcaps).

Comment 3 Bill Nottingham 2004-04-06 11:57:41 EDT
Do you get any SELinux errors when it's enabled?
Comment 4 Len Trigg 2004-04-12 22:58:53 EDT
Sorry, I have not tried reenabling selinux (haven't had time to muck
around with it, just needed to get the machine working) -- perhaps the
original reporter can check for errors.

Comment 5 Mike A. Harris 2004-04-13 16:36:05 EDT
reassigning to SElinux "policy" component as per above.  There's no
Xorg problem here that I can see.
Comment 6 Daniel Walsh 2004-04-22 14:53:31 EDT
I need some avc messages or something,  I have very little to go on here.

Dan
Comment 7 Leonard den Ottolander 2004-05-11 04:55:22 EDT
I seem to miss something about this bug. XF86Config? There is no
XFree86 in FC2t2. Changed to xorg. Are you editing the wrong file?

Note You need to log in before you can comment on or make changes to this bug.