Bug 1200354 - After latest update login to normal user failed. "su" to normal user also not possible. "bash" crashes
Summary: After latest update login to normal user failed. "su" to normal user also not...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Oprala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1200367 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 11:41 UTC by Jesús Salgado
Modified: 2016-02-01 02:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-17 08:19:19 UTC
Type: Bug


Attachments (Terms of Use)
PACKAGES UPDATED and LOG INFO (journalctl -b) (15.01 KB, text/plain)
2015-03-10 11:41 UTC, Jesús Salgado
no flags Details

Description Jesús Salgado 2015-03-10 11:41:55 UTC
Created attachment 999830 [details]
PACKAGES UPDATED and LOG INFO (journalctl -b)

Description of problem:
After latest update (see attached file for packages updated) it was not possible to login as normal user, either using a gdm sesion or via "su <normaluser>", after login as root. Only root can log in.

Once connected as root, the log system (via journalctl command) reports crash messages, apparently related to bash

Version-Release number of selected component (if applicable):
bash version 4.2.53(1)-release (x86_64-redhat-linux-gnu)

How reproducible:


Steps to Reproduce:
1. Update a number of packages (su -c 'yum update' followed by reboot)
2. Normal user failed to login. Root user can login
3. As root, su <normaluser> gets blocked. journalctl -b reports "crash in '/usr/bin/bash'"

Actual results:


Expected results:


Additional info:
Please, see attached file (packages updated, plus outputs of journalctl

Comment 1 Jesús Salgado 2015-03-10 12:20:05 UTC
Trying 'su <normaluser>' while logged in as root, it does not proceed. If I then cancel (Ctrl + C) it takes a while before responding and finally exists with the following message:

Cbash: $TMP: ambiguous redirect
bash: $TMP: ambiguous redirect
bash: [: : integer expression expected
Segmentation fault (core dumped)

Comment 2 Jesús Salgado 2015-03-10 12:33:56 UTC
Please, note, this is the same issue as Bug 1200367 - [abrt] bash: yyparse(): bash killed by SIGSEGV (edit), for which the report has been generated by abrt and is much more detailed.

Sorry if I am reporting duplicates. It is the first time that I report a bug.

Comment 3 Jesús Salgado 2015-03-10 14:04:20 UTC
I am able to create a new normal user with 'useradd', and login works perfectly for that user. The bash problem affects only one particular user normal user: the initially existing one. Attempts to "su" to that user get stuck with ~70% CPU usage, and finally get aborted with "bash: $TMP: ambiguous redirect" and "Segmentation fault (core dumped)" messages.

Comment 4 Jesús Salgado 2015-03-10 16:36:04 UTC
I found the caused of the problem, although I am not sure if I understand the reason...

First of all, it is not a "bash" bag and had nothing to do with updated packages from fedora.

Before the Fedora update, which I mentioned, I installed another program called "edirect" (a bunch of scripts from Entrez (PubMed, a bibliographic database). The automatic installation of that thing, added a new PATH to .bash_profile. It added as well a new line to .bashrc with "source ~/.bash_profile". Apparently, that makes bash crash.

I ignore if this is a bug of bash. I seems to me that it is simply a bad idea to "source" .bash_profile from .bashrc

Comment 5 Ondrej Oprala 2015-03-17 08:19:19 UTC
Well, by default ~/.bash_profile sources ~/.bashrc ...now when ~/.bashrc also sources ~/.bash_profile...I'm sure you get the idea...

So, I think we've found the problem :) Feel free to reopen if this is not your case.

Comment 6 Ondrej Oprala 2015-03-17 08:20:02 UTC
*** Bug 1200367 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.